Hosts file Problems

Discussion in 'Server Operation' started by xxdesmus, Mar 10, 2007.

  1. xxdesmus

    xxdesmus New Member

    Here is my problem, I followed the steps in this tutorial...

    Install Zimbra on Ubuntu

    And when I go to install Zimba (sudo ./ I get an error that I need to fix my hosts file

    Currently this is how it looks:

    Code:       localhost   localhost      mail
    What am I doing wrong? I've also tried just using as well and I still get the same error.

    Thanks for any suggestions guys...I am still a little green when it comes to Linux. (especially with networking)
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    Zimbra will be the MTA. Do not reference
    This is totally wrong. is an official name and I'm sure you're not the owner of 192.168 is a local ip address and you should "invent" your own name for is. Call it something like mail.myhome.loc.

    The /etc/hosts issue is discussed many, many times in the Zimbra forums. Maybe you should have a look there also?
  3. xxdesmus

    xxdesmus New Member

    still have problems,

    I changed my hosts file to this:
    Code:       localhost       localhost       ubuntu          ubuntu    mail.ubuntu.local       mail

    and I still get the error that I need to fix it ....I don't understand what I am doing wrong here. I was asking on this forum because the How To article specifically said "don't ask questions in the comments, ask in the forums"
  4. falko

    falko Super Moderator ISPConfig Developer

    IS there an MX record for You can check with
    dig mx
    Zimbra needs a valid MX record.
  5. xxdesmus

    xxdesmus New Member

    This is the output.

    ; <<>> DiG 9.3.4 <<>> mx
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 61453
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
    ;            IN      MX
    ;; AUTHORITY SECTION:             600     IN      SOA 3414054541 600 300 604800 600
    ;; Query time: 46 msec
    ;; SERVER:
    ;; WHEN: Sun Mar 11 17:01:49 2007
    ;; MSG SIZE  rcvd: 87
    As far as I can tell, this does indicate that I have a mx record correct?

    As you may have gathered, I am really quite clueless as to how to setup/config the hosts file ... This is what I have at the moment:

    Code:       localhost       localhost       ubuntu          ubuntu    mail.ubuntu.local       mail
    Do I need to include any where in the hosts file?
    Last edited: Mar 11, 2007
  6. falko

    falko Super Moderator ISPConfig Developer

    No, there's no MX record. If there was an MX record, there would be an answer section in the dig output (now you have a question and an authority section).
    Please create an MX record.

Share This Page