hosting web site problem/dns

Discussion in 'Installation/Configuration' started by andyreynolds, Feb 20, 2007.

  1. andyreynolds

    andyreynolds New Member

    I have followed the instructions for creating your own name servers so I have got ns1 and ns2 which look up to their respective IP addresses. I have created a master zone for the domain name but it doesn't seem to transfer to my servers. When I look up the domain with it returns my name servers as being the right ones but that is about it. I have also noticed that both of my servers are outputing the welcome to fedora apache test page. I have seen that on other fuctioning servers that the first IP address if you go to it comes with shared IP?? and the second server has this test page. Both of my servers have their test pages and I have followed the instructions whereby creating a DNS master and slave zone on the respective servers. I have given it 3 days since I transfered the domain to my name servers, but it still doesn't work. All the services on both servers are working ok and the DNS is set to ns1 and ns2 and their is no firewall on the router as I can access them from outside. What do I need to do???


    I have done that and each server returns their respective IP address. If i look up ns1 or at it returns the correct IP addresss of the server.
    when i look up the domain it returns the following error
    NS FAIL NS A timeout occurred getting the NS records from your nameservers! None of your nameservers responded fast enough. They are probably down or unreachable. I can't continue since your nameservers aren't responding. If you have a Watchguard Firebox, it's due to a bug in their DNS Proxy, which must be disabled (31 Jul 2006 UPDATE: several years after being informed of this, there is a rumor that there is a fix that allows the Watchguard DNS proxy to work).

    Does this mean BIND on my servers isn't working correctly even though they are configured right and the service is working?
    Searching for ALL record at []: Got referral to (zone: com.) [took 85 ms]
    Searching for ALL record at []: Got referral to (zone: [took 264 ms]
    Searching for ALL record at []: Timed out. Trying again.
    Searching for ALL record at []: Timed out. Trying again.
    Searching for ALL record at []: Timed out. Trying again.
    Searching for ALL record at []: Timed out. Trying again.
    Searching for ALL record at []: Timed out. Trying again.
    Searching for ALL record at []: Timed out. Trying again.

    even though I have got dns entries in both servers it comes up with these errors

    I am stuck on what I should enter into the settings page on ispconfig on each server. My NAT setup is that I have an internal network so each server has an IP address of 192.168.1.xx then my draytek router translates this into my ip addresses>131 I have followed the instructions on how to set up your own name server but I am not sure which IP address to put into the settings box it could either be or the subnet mask is and under the dns tab i have put in ns1 and ns2 I have allocated each server with ns1 and ns2 in their respective host name fields, but where i am stuck is when i transfer 2 domains these being and when i run a dns look up in dnshosting it finds the correct name servers but says that the ns records time out. I have checked my firewall which is disabled and both servers have all ports open to the net I tested this by using the port scanner under the tools button. I have seen that from set ups that are hosting websites successfully the IP of the main server has a shared IP message and the second server has the standard test page, I have this test page on both is that why it is not working?? i have created master and slave zones for the domain names its just a case of getting the BIND on the servers to talk to the outside world when queried.
  2. falko

    falko Super Moderator ISPConfig Developer

    If you're behind a router, you must forward port 53 (TCP and UDP!) from your router to your nameserver.
    The big problem then is that you can forward one port to only one system, so you can run one public nameserver in your local network, but not more.
  3. andyreynolds

    andyreynolds New Member

    My main name server has the ports 53 tcp and udp redirected to them. This is where the master records are kept for the domains. Surely if they are both DMZ then all ports are exposed to the internet?? I still think it has something to do with the fact that when you go on the ip address it comes up with the doman test page on both the internal and the external network instead of the shared IP which would suggest to me that the DNS setup is wrong, I didn't think that I needed to change the contents of the bind file because ispconfig does that all for you. Why should they be timing out like the error above, because they have had 2 days to propergate, but yet still on the domain which points to my name servers which both have the master and slave records as outlined in the dbs how to with go daddy. If you go to you can query my name servers and they come up with my IP addresses. Is this a problem with the configuration of isp config?? you can login to my main name server the username is admin and the password is agst89f I have used the update manager to use the remote framework beta, but now when you click on tools there is nothing there??
  4. falko

    falko Super Moderator ISPConfig Developer

    Maybe there's something wrong with your router/firewall because
    dig @
    also doesn't work.
  5. andyreynolds

    andyreynolds New Member

    mysql dns status

    i will try and install your dns mysql software, would this be more effective than the dns under the isp config?
  6. falko

    falko Super Moderator ISPConfig Developer

    Technically there's no difference. The name servers are different (BIND vs. MyDNS), but I don't think your problem is related to BIND. It sounds like a firewall issue to me or something like that.
    And keep in mind that you cannot use MyDNS if you have ISPConfig installed.
  7. andyreynolds

    andyreynolds New Member

    requested qoute from virtual hosts file


    I am not going to use the my DNS service I am going to use the ISP config bind. I am now using the latest version of ISP config. Is this qoute right?

Share This Page