Hosting HTTP but not MX, postfix error

Discussion in 'Installation/Configuration' started by FarrisGoldstein, Dec 18, 2006.

  1. FarrisGoldstein

    FarrisGoldstein New Member

    I'm hosting the web site of, but my site is not the true SOA for, nor is it the mx. However, my server IS an MTA for several other sites, some of which need to send mail to users at When a mail user on my box tries to send mail to a valid [email protected] address, postfix throws the error:

    Recipient address rejected: User unknown in local recipient table.
    I assume this is because, when you setup a site in ISPConfig, as well as users, it automatically adds lines to postfix's virtusertable. So postfix sees that there are addresses at the site, but not the one being addressed in this message, so it rejects the message.

    How do I get postfix to honor the MX of the domain before it cares about what is in virtusertable?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can use on your server as email domain (what you are currently doing) or you set to external mailserver (in the website and the co-domain!) and all mail for will be sent to the correct mail exchanging server for and not to your local server.
  3. FarrisGoldstein

    FarrisGoldstein New Member

    I'm not sure I understand how to set it to external mailserver. I defined an external MX, but I still get the same error when sending. I can't setup mail forwards for every mail user on that domain, as I'm not in control of the mail accounts at the MX.

    The SOA for the domain is not my box. The domain just has an A name to my box at their external DNS server. However, after adding the site through ISPConfig, my box of course believes it is the SOA for the domain.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You must set it to external mailserver in the co-domain of this website too.

Share This Page