Hosting dns on CL but postifx issues.

Discussion in 'General' started by ozgurerdogan, Apr 21, 2020.

  1. ozgurerdogan

    ozgurerdogan Member

    After I moved dns to CL,
    Postfix logs:
    Apr 21 09:55:33 sunucu postfix/smtpd[7023]: NOQUEUE: reject: RCPT from unknown[178.210.162.65]: 450 4.7.1 <externaldomian.here>: Helo command rejected: Host not found; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<externaldomian.here>
    But before holding dns records on ispconfig, there were no issue? I have deleted dns records and unchecked dns server in server config.
    I do not want to edit main.cf in postfix to allow reject_unknown_helo_hostname in postfix which may increase spam mails.
    Could this be because I was still holding dns records even I moved them to Cloudflare ? Should I wait?
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    If you just changed DNS records, you should wait 4 to 8 hours for the information to propagate over the Internet. Sometimes longer.
    Check first from the authoritative name servers of your domain that they do indeed answer correctly.
     
  3. ozgurerdogan

    ozgurerdogan Member

    I do not think this is related to dns propagation. Also both dns records have same values.
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    So what is the problem?
    If you mean the postfix log lines you showed in #1, I get similar entries on my e-mail servers all the time. It looks like it is incoming mail and sending host does not have proper configuration in name service or is otherwise misconfigured. So sender is probably spammer.
     
    Last edited: Apr 21, 2020
  5. ozgurerdogan

    ozgurerdogan Member

    Yes but my client says, they were able to send and recieve from those domain BEFORE I move dns records to CF. That makes me confused.
     
  6. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    That means the message was rejected because the helo hostname (externaldomain.here) is not found in DNS. Add an A record for externaldomain.here.
     
  7. ozgurerdogan

    ozgurerdogan Member

    yes ı know. but my client claims they were able to recieve mails before i move the dns to cf which seems weird...
     
  8. Jesse Norell

    Jesse Norell ISPConfig Developer ISPConfig Developer

    I would assume that externaldomain.here had an address in your old dns setup, and it does not now .. nothing weird going on. The most obvious answers are usually the most likely...
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    When you are long enough in business, then you'll learn that clients claim many things, some of them are correct and others not. It does not mean that the client tries to trick you, they just don't know it better. So if something is not logical, then it's often better to assume that it did not happen in the way you were told that it happened unless you have seen it yourself :)

    Back to your problem, the issue is clear, postfix is not able to resolve the mentioned hostname, so itb either does not exist or it's a propagation or caching issue, assumed that there is no general issue in that server with name resolution. Fix that and it will work :)
     
  10. ozgurerdogan

    ozgurerdogan Member

    :) I totally agree with you and perfectly understand what you mean. Sometimes, I think of making of a blog of those clients' claims just for fun...
    I am doing this business for 16 years. But such long time also teached me there is always %1 times that I must not be sure in advance and i could be missing somepoint because of some relational issiues.

    I already told my client about the fix but as I am new to ispconfig, just wanted to make it sure. Otherwise error is obvious...
     
    till likes this.
  11. nhybgtvfr

    nhybgtvfr Active Member

    hehe, see this one a lot, the one I like is where a server connects and tries to send an helo with a server name like mail.localdomain
    when you tell them they're own mailserver is misconfigured they always claim their server is configured fine and works everywhere else.
    even when you send them that bit of log as proof...
    customers.... can't make money without them, can't train them.. can't shoot them.. ;)
     

Share This Page