host www ignored

Discussion in 'Installation/Configuration' started by mgg75, Dec 24, 2008.

  1. mgg75

    mgg75 New Member


    I've been using ispconfig for a while and think it's brilliant.

    Recently I ran into the following configuration issue which I am struggling to get to the bottom of.

    Basic Config as follows:
    ISPConfig 2.2.29 running on Debian Etch (According to S.F. Perfect setup)
    3 IP Addresses each running seperate web sites with SSL enabled.

    The third IP address and web site was added recently. In this site I wanted to use a wildcard for the domain. As my registrar (1and1) does not support wildcard sub domains I followed S.F guide (based on GoDaddy) to use ISPConfig as my DNS server for website3 domain. All seemed fine, any subdomain gets correctly served by ISPConfig both SSL and non SSL.

    However, if I try to access ISPConfig serves a page explaining that the web site needs to be accessed by name. (seems like ISPConfig is getting the request on the wrong IP address) Yet works as expected (I have added * (host) with as a co-domain for this site and included * as a host in DNS A record). When I ping it resolves to the correct IP address. If I check the DNS server with Dig all seems well. The host name for the web site is set to www in ISPConfig.

    In an attempt to simplify I got rid of the wildcards and tried to set up plain vanilla . Even this does not work, yet the other two sites were fine. So now have re-implimented wildcards so I at least have a way of viewing the site. :confused:

  2. mgg75

    mgg75 New Member


    I've been trying to see if there is some relevant information in the website logs. Not much joy as these only seem to be written every 24hrs...(Will not be popular if I even look at a PC tomorrow :) ) Appologies for a silly question but where do I find the "up to the minute" logs?

    and compliments of the season to all
  3. falko

    falko Super Moderator ISPConfig Developer

    What's in your Vhosts_ispconfig.conf, and what's the output of

    show the correct IP address?

Share This Page