Host transfer problem

Discussion in 'Technical' started by el-sid, Aug 7, 2008.

  1. el-sid

    el-sid New Member

    hi,

    i just transfered a site with database from one host provider to another
    the ftp transfer went on successfully so did the database transfer.
    However, when i try loggin in to the admin in the new hosting account, i get an
    error - that the user credentials are wrong.

    the problem is i counter checked the username and password in the database and they are the same as they were before the transfer.

    any ideas?
    please help
    thanks in advance.

    i forgot to add something

    the account i moved has php/mysql web applications
    so when i try to login the admin eg www.example.com/admin
    i get a login page. but the passwords i used to use are not working
    NOTE: the login page is not for the cpanel
     
    Last edited: Aug 7, 2008
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you move over the user records from the mysql.user table as well?
     
  3. el-sid

    el-sid New Member

    i caused a mysql dump using phpMyAdmin and imported to the new database. am not sure what you mean by mysql.user
    table, but if it is the table used to store mysql user accounts, i used a different username and password. and modified accordingly in the config.inc.php file of the web application.

    The site is up and running. it can access the database, but the admin section is the one with issues.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Yes, that's the table I mean. Did you restart MySQL afterwards or run
    Code:
    FLUSH PRIVILEGES;
    after your changes to the user table?
     
  5. el-sid

    el-sid New Member

    sorry for delay. i did not FLUSH PRIVILEGES on the new database. so i tried what you suggested through phpMyAdmin but got this error
    Code:
    #1227 - Access denied; you need the RELOAD privilege for this operation 
    
    i googled it and the general consensus was that i should have the web admin do it for me.
    is that right?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    You must do this as the root MySQL user. But it's easier to just restart MySQL - it has the same effect.
     
  7. el-sid

    el-sid New Member

    Hi falko,

    thanks for replying. i tried to shutdown and restart but that option is not in my phpMyAdmin. i at least know the option is supposed to be in home -> privileges. the host server is using version phpMyAdmin 2.9.1.1.

    but i still don't understand how it could be a mysql user accounts issue. The user name and password that are not authenticating are in a custom created accounts table so therefore i suspected issues with php authentication. please help me understand :confused::confused:
     
  8. el-sid

    el-sid New Member

    hi,
    i got another way to test the FLUSH PRIVILEGES
    i installed the backup site in my local server. setup everything-from db username and passwords and then FLUSH PRIVILEGES as root. it did not work. i checked my server error log and it gave me this error
    Code:
    [Mon Aug 11 01:42:17 2008] [error] [client 127.0.0.1] PHP Fatal error:  Call to undefined function imagecreatefromjpeg() in /var/www/html/public_html/getsnap.php on line 218, referer: http://localhost/public_html/
    
    the thing is i know for certainty that theres nothing wrong with the code. could it have to do with permisions. because i had to chmod several areas to gain access
     
  9. falko

    falko Super Moderator ISPConfig Developer

    This error message has nothing to do with MySQL. It means that the PHP-GD module is not installed or enabled.
     

Share This Page