host 25 greeted me with my own hostname

Discussion in 'HOWTO-Related Questions' started by thabangk, Nov 2, 2009.

  1. thabangk

    thabangk New Member

    Hi All

    I tried creating mail directory by sending mail to thabang@kgautle.biz using mailx thabang@kgautle.biz and i got this error in the maillog

    Nov 2 06:08:30 rq3thabang postfix/smtpd[3374]: connect from unknown[internal firewall IP]
    Nov 2 06:08:30 rq3thabang postfix/smtp[3373]: warning: host rq3thabang.selfip.biz[external firewall IP]:25 greeted me with my own hostname rq3thabang.selfip.biz
    Nov 2 06:08:30 rq3thabang postfix/smtp[3373]: warning: host rq3thabang.selfip.biz[external firewall IP]:25 replied to HELO/EHLO with my own hostname rq3thabang.selfip.biz
    Nov 2 06:08:30 rq3thabang postfix/smtp[3373]: 13468528033: to=<thabang@kgautle.biz>, relay=rq3thabang.selfip.biz[external firewall IP]:25, delay=0.35, delays=0.03/0.01/0.31/0, dsn=5.4.6, status=bounced (mail for thabang.dyndns.tv loops back to myself)
    Nov 2 06:08:30 rq3thabang postfix/smtpd[3374]: disconnect from unknown[internal firewall IP]

    And by the way i created my hostname and MX records using dynamic DNS.and the Mx are pointing to the right machine but what confusing is i can send mail to other domain using mailx but i can't.

    rq3thabang@selfip.biz = hostname
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please add thabang.dyndns.tv to the mydestination line in /etc/postfix/main.cf and restart Postfix.
     
  3. thabangk

    thabangk New Member

    Hi

    Still the same

    i just got this again

    rq3thabang postfix/smtpd[3347]: connect from unknown[192.168.10.221]
    Nov 3 05:49:46 rq3thabang postfix/smtp[3343]: warning: host thabang.dyndns.tv[41.160.145.12]:25 greeted me with my own hostname rq3thabang.selfip.biz
    Nov 3 05:49:46 rq3thabang postfix/smtp[3343]: warning: host thabang.dyndns.tv[41.160.145.12]:25 replied to HELO/EHLO with my own hostname rq3thabang.selfip.biz
    Nov 3 05:49:46 rq3thabang postfix/smtp[3343]: 204AD5280BA: to=<thabang@kgautle.biz>, relay=thabang.dyndns.tv[41.160.145.12]:25, delay=0.53, delays=0.01/0.01/0.51/0, dsn=5.4.6, status=bounced (mail for thabang.dyndns.tv loops back to myself)
    Nov 3 05:49:46 rq3thabang postfix/smtpd[3347]: disconnect from unknown[192.168.10.221]

    and my dyndns settings are like this
    thabang.dyndns.tv Host 41.160.145.12(firewall external ip)

    192.168.10.221 is my internal IP 4 ipcop.
    my server is behind the firewall and the internet modem.so the only erxternal ip recongnised is 41.160.145.10 so i opened port 25 on the firewall pointing to the mail server

    Any idea what may be causing this.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's in your main.cf?
     
  5. thabangk

    thabangk New Member

    Thats my uncommented lines in my main.cf

    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    mydestination = rq3thabang.selfip.biz, localhost, localhost.localdomain,thabang.dyndns.tv
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
    PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man

    sample_directory = /usr/share/doc/postfix-2.3.3/samples

    readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
    myhostname = rq3thabang.selfip.biz
    mynetworks = 127.0.0.0/8
    virtual_alias_domains =
    virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
    virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
    virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
    virtual_mailbox_base = /home/vmail
    virtual_uid_maps = static:5000
    virtual_gid_maps = static:5000
    smtpd_sasl_auth_enable = yes
    broken_sasl_auth_clients = yes
    smtpd_sasl_authenticated_header = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
    smtpd_use_tls = yes
    smtpd_tls_cert_file = /etc/postfix/smtpd.cert
    smtpd_tls_key_file = /etc/postfix/smtpd.key
    transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
    virtual_create_maildirsize = yes
    virtual_maildir_extended = yes
    virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
    virtual_mailbox_limit_override = yes
    virtual_maildir_limit_message = "The user you are trying to reach is over quota."
    virtual_overquota_bounce = yes
    proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
    content_filter = amavis:[127.0.0.1]:10024
    receive_override_options = no_address_mappings
    home_mailbox = Maildir/
    mailbox_command =
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you change
    Code:
    myhostname = rq3thabang.selfip.biz
    to
    Code:
    myhostname = thabang.dyndns.tv
    and restart Postfix?
     

Share This Page