Horde problem

Discussion in 'Installation/Configuration' started by Snowman, Aug 22, 2014.

  1. Snowman

    Snowman Member

    I am sick of debugging for 5 hours and I need help from community.
    My problem : Horde do not showing filters

    Can you lead me what can cause the problem?

    backend.local.php of INGO is like
    $backends['imap'] = array(
    'disabled' => true,

    $backends['sieve'] = array(
    'disabled' => false,
    'transport' => 'timsieved',
    'hordeauth' => 'full',
    'params' => array(
    'hostspec' => '',
    'logintype' => 'PLAIN',
    'usetls' => false,
    'port' => 4190,
    'scriptname' => 'ingo',
    'debug' => true,

    'script' => 'sieve',
    'scriptparams' => array(
    'utf8' => true,
    'shares' => false

    I am able to connect to 4190 port and also activate the default sieve script from horde like :

    1: # Sieve Filter
    2: # Generated by Ingo (http://www.horde.org/ingo/) (22/08/2014, 18:49)

    There is some option where to set which filters i will see or which i will not ?

    [email protected]:/var/www/ingo/config# telnet 4190
    Connected to
    Escape character is '^]'.
    "IMPLEMENTATION" "Dovecot Pigeonhole"
    "SIEVE" "fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave"
    "NOTIFY" "mailto"
    "VERSION" "1.0"
    OK "Mailserver ready."

    Thanks FOR ANY HELP!

  2. dcurrey

    dcurrey Member

    Man it has been some time sine I set this up. But here is my config


    $backends['imap']['disabled'] = true;
    $backends['sieve']['disabled'] = false;
    $backends['sieve']['script'][Ingo::RULE_ALL]['params']['utf8'] = true;
    I think the key was the hooks.php file

     * Ingo Hooks configuration file.
    class Ingo_Hooks
         * Returns the username/password needed to connect to the transport
         * backend.
         public function transport_auth($driver)
             switch ($driver) {
             case 'timsieved':
                 return array(
                     'username' => $GLOBALS['registry']->getAuth(null),
                     'euser' => $GLOBALS['registry']->getAuth(null)
    I know I had to edit some other file in in ingo directory something about imap4flags. I will have to see if I can find it, or maybe it was something in dovecot.
  3. Snowman

    Snowman Member

    Hi there,
    thanks, but above code in hook.php do not solve problem.
    I still dont see filters :(

    Anyone have some idea?
  4. dcurrey

    dcurrey Member

    What version of Horde and dist of linux are you working with.

    Your output from the telnet 4190 is similar to mine.

    Are any files being created in /var/vmail/yourdomain.com/user and /var/vmail/yourdomain.com/user/sieve
  5. Snowman

    Snowman Member

    It's ok now. Thanks for help. But another problem is there.

    All horde services running OK, i can login-in to webmail, send emails, receive emails, setup filters also(ingo), all working.
    But i can’t logout from webmail and also i can’t save changes in my settings when i am logged to webmail. There is no error log in DEBUG horde of IMP and all horde..

    Horde AJAX will throw this every time I click logout or when i hit save in profile preferencies:
    We cannot verify that this request was really sent by you. It could be a malicious request. If you intended to perform this action, you can retry it now.

    $conf['session']['name'] = 'Horde';
    $conf['session']['use_only_cookies'] = true;
    $conf['session']['cache_limiter'] = 'nocache';
    $conf['session']['timeout'] = 0;
    $conf['sql']['username'] = 'horde';
    $conf['sql']['password'] = ‘password';
    $conf['sql']['protocol'] = 'unix';
    $conf['sql']['database'] = 'horde';
    $conf['sql']['charset'] = 'utf-8';
    $conf['sql']['ssl'] = false;
    $conf['sql']['splitread'] = false;
    $conf['sql']['phptype'] = 'mysqli';
    $conf['datatree']['driver'] = 'sql';
    $conf['share']['cache'] = false;
    $conf['cache']['default_lifetime'] = 86400;
    $conf['cache']['driver'] = 'Apc';
    $conf['cache']['compress'] = true;
    $conf['cache']['use_memorycache'] = '';
    $conf['cachecssparams']['driver'] = 'filesystem';
    $conf['cachecssparams']['lifetime'] = 86400;
    $conf['cachecssparams']['compress'] = 'php';
    $conf['cachecss'] = true;
    $conf['cachejs'] = false;
    $conf['cachethemes'] = false;
    $conf['sessionhandler']['params']['driverconfig'] = 'horde';
    $conf['sessionhandler']['type'] = 'Sql';
    $conf['sessionhandler']['memcache'] = false;
    $conf['memcache']['enabled'] = false;

    This is config.

    Any thoughts ?
    Thanks for help.

  6. dcurrey

    dcurrey Member

    Honestly no clue on this one.

    It looks like you are tying to use sql database as sessionhandler. Have you tried the default PHP session handler?

    Also some cookie blockers might cause a similar behavior.
    Last edited: Aug 27, 2014

Share This Page