Horde 4 with SSL

Discussion in 'Installation/Configuration' started by sjswarts, Jun 22, 2012.

  1. sjswarts

    sjswarts New Member

    G'day guys,

    For awhile now I have wanted to implement Horde 4 on ISPConfig to give me a "exchange" like ability. I needed 3 things.
    1. IMAP email
    2. Synchronized Contacts
    3. Synchronized Calendars

    Now I followed this tutorial - http://www.howtoforge.com/install-horde-4-webmail-for-ispconfig-on-debian-squeeze-through-pear

    All works well, even ActiveSync (just remember that Exchange option on your iPhone automatically checks for SSL connection so turn that off) but how do I configure Horde to use SSL (I have a Legit Certificate)

    Thank you in advance,
    Your work is GREATLY appreciated!!

  2. sjau

    sjau Local Meanie Moderator

    just enable the SSL VHost and also put the same directory and alias stuff in there...
  3. sjswarts

    sjswarts New Member

    Thank you for the reply sjau,

    Do you mean the SSL Vhost in ISPConfig? For my website?

    I don't understand exactly what you mean?

    Could you break it down into the dummy version :D
    Also I just realized that emails aren't syncing with my iPhone. Should I make another Thread?

    Oh and one other thing in your tutorial it says:

    12. Edit /var/www/horde/conf/conf.php

    But on my instance of Debian Horde conf.php is actually installed into:


    just a little thing...

    By the way thanks for the guide it is very helpful.

  4. sjau

    sjau Local Meanie Moderator

    enabling https in ipsc should work fine.... the whole horde specific stuff is in conf.d which should be autoincluded I think... can't test it myself.

    thx regarding the config/conf confusion. Gonna fix it now.

    And regrading email: Horde doesn't support email sync through AS yet. However you can use another email client. On my Android I use K9 as email client with multiple different IMAP accounts.
    Last edited: Jun 22, 2012
  5. sjswarts

    sjswarts New Member

    Ok I'll give that a try... Currently I have an operational ISPConfig with Roundcube and I wanted to just add Horde to it. So far the test system (nothing on it) worked so I'll post back if its working and what I did.

    As for the Active Sync email, it appears to be coming in Horde 5?? http://wiki.horde.org/ActiveSync

    So do you setup for example on the iPhone 2 accounts, 1 is Exchange with Contacts and Calendar enabled and the other is an IMAP account for the Email??

    The ultimate system then would be ISPConfig and Horde with FULL activesync abilities. I wish that more people with knowledge could help the guys out at horde.org - Just saying ;)
  6. sjswarts

    sjswarts New Member

    Hi guys,

    I have successfully (i think) migrated my old virtual server to a working version of ISPConfig 3 with Horde 4 installed. I can access my emails, calendar and contacts just great through my ip 192.168.XXX.XXX/horde

    The issue still remains though that I've implemented SSL, redirects and edited conf.php

    $conf['use_ssl'] = 1; # 1 is force SSL

    It redirects fine but Horde doesn't work with SSL...
    What am I doing wrong?

  7. sjau

    sjau Local Meanie Moderator

    can you access it by ssl or does that not work either?
  8. sjswarts

    sjswarts New Member

    g'day sjau,

    don't know what I did wrong but hyper_ch on the horde irc channel helped out and told me to add this to my horde.conf file...

    AddType application/x-httpd-php .php
    So in complete form it looks like this...

    Alias /autodiscover/autodiscover.xml /var/www/horde/rpc.php
    Alias /Microsoft-Server-ActiveSync /var/www/horde/rpc.php
    Alias /horde /var/www/horde
    <Directory /var/www/horde>
               Options +FollowSymLinks
               AllowOverride None
               order allow,deny
               allow from all
               AddType application/x-httpd-php .php
               php_value include_path ".:/usr/share/php"
               php_value open_basedir "none"
               php_value upload_tmp_dir "/var/www/horde/phptmp/"
    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    This enables me to run on both http and https but I want to FORCE https...

    My issue now is that the rewrite doesn't work... people can still access my site by using port 80
  9. sjau

    sjau Local Meanie Moderator

    Just put it as .htaccess in your domain folder

    RewriteEngine On
    RewriteCond %{HTTPS} off
    RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
    e.g. /var/www/domain.com/web/.htaccess
  10. sjswarts

    sjswarts New Member

    sjau - won't that force SSL on everything not just horde?? for example my website I don't care that they look at in http but only things regarding to log in and personal information I want to have in https...

    I have been able to use Horde's in app configuration to successfully implement this. All you need is to have horde working, accessible by https (ssl) and the admin account created when you installed horde. Now navigate like this:

    1. Log in to horde using Admin account - VERY IMPORTANT!!!!
    2. Left hand column should show Administration - click that
    3. Under the Administration tree you should see Configuration - click that
    4. All the applications should show and you should see Horde - click that
    5. Under the heading URL Settings you should see a drop down menu for $conf[use_ssl] - click that
    6. Select Assume that we are using SSL and always generate https URLs
    7. Scroll to the bottom of the page and click Generate Horde Configuration
    8. Now log out, clear browser cache, re-fresh log in page and happy days horde runs in SSL :D

Share This Page