Horde 4 / Ubuntu 12.04

Discussion in 'Server Operation' started by blinky, Sep 27, 2012.

  1. blinky

    blinky Member

    Trying to login as the configured administrative mail use, I get the following error in my browser:

    A fatal error has occurred
    SQLSTATE[42S02]: Base table or view not found: 1146 Table 'horde.horde_perms' doesn't exist

    Anyone seen this error or know how I might resolve it?

    I have already completely removed Horder and resinatlled it a second time in an attempt to resolve this issue but come up with the same error second time around.
  2. XinuL

    XinuL New Member

    I'm getting the same issue...
  3. XinuL

    XinuL New Member

    It looks like we were following the same instruction set on how to build a mail server with Horde/Dovecot/Postfix/Ubuntu. Maybe there's something wrong with the document?
  4. mmidgett

    mmidgett Member

    I had the same issue on 12.04 but not on 10.04. Just removing the horde directory is not enough to remove it How to uninstall horde

    After I did this and started the re-install I was able to get the horde installer to finish and get the web GUI up but it wouldn't take any logins and didn't really put any messages into my mail log other than a connection to impd on and then closed it. I am still looking to resolve this issue and will be re-installing today to see if something else is wrong. I have also followed the instructions from the horde wiki but was unable to make that work also.
  5. blinky

    blinky Member

    After two days of intensive hair-pulling, removing and installing Horde THREE times (all of which garnered no success) I finally concluded that Horde was simply not the webmail solution I needed on Ubuntu 12.04 Postfix/Dovecot.

    I opted, instead, for RoundCudeMail which was reasonably easy to install. Only one tricky issue... a pear sql Driver MD2 or something like that which, when you get the error trying to communicate with MySQL, you'll be able to find the driver via Google.

    RouncCubeMail is now up and running and simply a much, much easier alternative that the exhaustive process I went through with my Horde experience. Also only two commands to install from the command line instead of the gazillion Horde takes.

    Still testing RoundCubeMail but thus far it seems to work just fine.
  6. XinuL

    XinuL New Member

    I just finished installing RoundCube...pretty awesome!
  7. ronaldvg

    ronaldvg New Member

    Fixing the horde install

    I ran into the same issue. To address is do this:

    cp /var/www/config/conf.dist.php /var/www/config/conf.dist

    this overwrites the conf.php from the tutorial with the default conf.php from the horde install.

    now run 'sudo webmail-install'

    I chose the following options:
    - mysql
    - 0
    - horde
    - <horde db password>
    - tcp
    - (my database is on the same server as horde webmail)
    - 3306
    - horde
    - utf-8
    - 0
    - blank
    - false

    then enter the email address of the adminstrator and you are done.

    now if you browse to mail.example.com you will get the login prompt. Login with the admin email/pwd and follow the instructions again.

    Good luck,

Share This Page