/home ad symlink after rsync run

Discussion in 'General' started by DreamK, Mar 8, 2010.

  1. DreamK

    DreamK New Member


    At the first time, sorry to mind you.

    I have proceed urgently to a faulty hard drive replacement. I have done a rsync run and i have lost all the symlink.

    There is a way to proceed to restore all the symlink in /home ?

    Thanks in advance for you reply :)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You mean the symlinks for the websites in ispconfig? Set the field "status" in the isp_isp_web table in the ispconfig database to 'u' and then edit one website and save it. ISPConfig will then recreate the links.
  3. DreamK

    DreamK New Member

    ok, a part of the symlink have been restored.

    The website with no symlink are those with active web logs.

    web[id] -> /log empty
    www.web[id] -> /log working

    Should I cut and past the /log into web[id] for each website ?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The symlinks should not depend on the logfiles. Also if log is empty, this would mean that the site is not in use. Do you have any errors in the file /home/admispconfig/ispconfig/ispconfig.log
  5. DreamK

    DreamK New Member

    I have this logs after having set an option for webalizer on web2

    - I have manualy cut and past the log file
    - set option "u" to recreate de ln -s link
    - forced the log creation
    ... webalizer is analyzing 300Gb of stat logs
    Last edited: Mar 8, 2010

Share This Page