HHVM Error on Ubuntu 16.04

Discussion in 'ISPConfig 3 Priority Support' started by BobGeorge, Nov 25, 2017.

  1. BobGeorge

    BobGeorge Member HowtoForge Supporter

    There seems to be a problem with HHVM on Ubuntu 16.04 because when I run a "sudo apt update" on any of the nodes (or even my laptop here), I'm getting the following error:

    Code:
    Err:5 http://dl.hhvm.com/ubuntu xenial InRelease
      The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B4112585D386EB94
    I've tried removing the repository, re-downloading the key, adding the repository back - as per the standard instructions in "perfect server" and elsewhere - and re-installing from scratch but this error persists.

    Does anyone else have this issue? Have Facebook changed the keys or made an error in packaging things for 16.04?
     
  2. Jeremiah K

    Jeremiah K New Member HowtoForge Supporter

    Try:
    Code:
    sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B4112585D386EB94
    
     
  3. BobGeorge

    BobGeorge Member HowtoForge Supporter

    Directly, that didn't work.

    But on a hunch from how it's done in "perfect server", I made a little amendment to the url and that did actually work. So this is the actual command that fixed it:

    Code:
    sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys B4112585D386EB94
    The command you supplied simply doesn't connect. So, apparently, specifying the protocol and then ensuring it goes via port 80 - possibly to get it through some firewall rules that won't allow non-port-80 traffic in - seems to be required.

    Also, the number you supplied - B4112585D386EB94 - is different to the number - 5A16E7281BE7A449 - found in "Perfect Server" (and other pages I found about installing HHVM).

    So the key has changed? How did you discover what the correct key was?

    Just, you know, in the interests of "teach a man to fish", so that if something like this happens again, I know how to obtain the new number myself and won't have to bother anyone about it. Because I did try googling for it (as the error messages - as well as the fact that it did used to work and then it suddenly stopped working on all the machines I had installed HHVM to - suggested to me that the key must have changed), but all the HHVM installation instructions I could find use the old "5A16E7281BE7A449" number and not the one you supplied.

    Plus, if the key has changed, then the "Perfect Server" instructions will probably need updating.
     
  4. Jeremiah K

    Jeremiah K New Member HowtoForge Supporter

    Sure, it's good to know how to catch this fish. I run into it a lot. Search Startpage for "NO_PUBKEY" and you'll find discussions/methods for searching keyservers for missing keys.

    You supplied the ID for the missing key:

    Yeah, they must have an old key in the tutorial. Until it's updated, maybe leave a comment at the bottom for the next guy? I'm glad that you were able to get it resolved.
     
    Last edited: Nov 26, 2017
  5. BobGeorge

    BobGeorge Member HowtoForge Supporter

    I've posted a comment with the information. Although, it requires manual approval anyway, before the comment will publish, so perhaps whoever's doing the approving could just alter the tutorial itself directly instead.

    I'll leave it in their hands.
     

Share This Page