HHVM created with ISPconfig permission denied

Discussion in 'Installation/Configuration' started by pchott, Feb 28, 2017.

  1. pchott

    pchott New Member

    I was playing today with HHVM and I am getting permission denied on a socket.

    [crit] 5823#5823: *7 connect() to unix:/var/run/hhvm/hhvm.web00.sock failed (13: Permission denied) while connecting to upstream, client: XX.YY.ZZZ.WW, server: domain.my, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/hhvm/hhvm.web00.sock:", host: "domain.my"

    -rw-r----- 1 web00 client01 4 Feb 28 11:55 hhvm_web00.pid
    srwxrw---- 1 web00 client01 0 Feb 28 11:55 hhvm.web00.sock

    HHVM is installed and working (tested with connection on port 9000). But there seems to be some problems with sock option.

    Any idea what did I do wrong?
     
  2. Tuumke

    Tuumke Member

  3. Tuumke

    Tuumke Member

    @pchott
    I just noticed there was another update for HHVM.
    I did apt-get update && apt-get upgrade > Reboot
    Sites are working again
     
  4. pchott

    pchott New Member

    Could not reboot production server :p but i did upgrade. That was noth enought.

    But I just find ouf that adding users "www-data" and "nginx" to client group solves the problem. I'll do some more tests to see if that reall works every time
     
  5. ahrasis

    ahrasis Well-Known Member

    Actually there is no need to reboot especially if all relevant services are already restarted / reloaded.
     

Share This Page