hepl error mod_fcgid when install zend opcache

Discussion in 'Programming/Scripts' started by momo1240, Jan 15, 2016.

  1. momo1240

    momo1240 Member

    any help guys ?
    so After installing opcache and put the path on opache.ini
    everything seems to be fine
    when I check with php -v , I don't have any error and it tells me that zend opcache is installed
    But when I try to access to my website or ispconfig panel I have an error.
    I check the logs this is what I have :
    [warn] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [warn] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function


    Thank you for your help
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Which os?
     
  3. momo1240

    momo1240 Member

    Hello Till
    thank you for your help
    I'm using debian 6 with ispconfig php 5.3.3, fastcgi and suexec activated for my prestashop website
    when I activated zend opcache, I can't access to my website and ispconfig panel too
    and I have this error
    [warn] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    [warn] (104)Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function


    thank you
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The commandline php and the fcgi php have both their own php.ini files. check with phpinfo() in the webiste to see which php.ini it uses and add zend opcache to that file as well.
     
  5. momo1240

    momo1240 Member

    thank you for your reply and your help till
    but it not only about my website, I can't access to my ispconfig panel too when I activate opcache on /etc/php5/conf.d/opcache.ini
    so what I see is that when I added zend_extension=/usr/lib/php5/20090626/opcache.so to /etc/php5/cgi/php.ini, the website works but I have 500 error when I try to access to my ispconfig panel
    thank you
     
    Last edited: Jan 15, 2016
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The ISPConfig interface is basically a website too. So when opcache is installed wrongly in fcgi ini so that al fcgi php processes fail, then this will affect your sites and ispconfig.
     
  7. momo1240

    momo1240 Member

    thank you for your reply till
    so can you tell me please which fcgi ini file should I update with zend_extension=/usr/lib/php5/20090626/opcache.so
    in order to have opcache installed in all websites and ispconfig
    thank you
     
    Last edited: Jan 28, 2016
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Put a php file with the content:

    <?php
    phpinfo();
    ?>

    into the website, open it in a browser and it will show you the path to the php.ini used by this php instance.
     
  9. momo1240

    momo1240 Member

    thank you again for your help till

    so this is what I've tried
    after installing zend opcache, I log in ispconfig panel,
    I select my website and in "Custom php.ini settings" I added zend_extension=/usr/lib/php5/20090626/opcache.so
    so when I checked my phpinfo file , it tells me that opcache is activated and running But I can't access to my website I have an error 500 and I have this on the logs
    Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function


    so I decided to add zend_extension=/usr/lib/php5/20090626/opcache.so in /etc/php5/cgi/php.ini
    after that my website is available I don't have error 500
    but when I check phpinfo, I have the opcache config but it tell me that opcache is disabled and not running

    I attached phpinfo directories

    thank you for your help

     

    Attached Files:

    Last edited: Feb 5, 2016
  10. ztk.me

    ztk.me Active Member

  11. momo1240

    momo1240 Member

    thank you for your reply
    I tried this too :
    After installing zend opcache, I created opcache.ini in /etc/php5/conf.d with zend_extension=/usr/lib/php5/20090626/opcache.so
    when I checked it tell me that opcache is activated and running
    but when I tried to access to my website and ispconfig panel, I have 500 error with this in error log
    Connection reset by peer: mod_fcgid: error reading data from FastCGI server
    Connection reset by peer: mod_fcgid: ap_pass_brigade failed in handle_request_ipc function

    so I checked with cfgi, opcache.ini is in /etc/php5/cgi/conf.d
    so I don't know where this error come from (only when opcache is activated)

    thank you again
     
  12. ztk.me

    ztk.me Active Member

    I'm not quite sure but I think it was debian 6, maybe 5 having very unstable mod_fcgi and unuseable mod_fastcgi support ( needed to manually load sources including later released patches ) .

    Is mpm_prefork active? Any other opcode caches like APC/xcache/eAccelerator?
    What happens if you create a test website using mod_php ( if installed ) and then enableing zend opcache.so does that work?

    But honestly, the error messages are not helping much ( not your fault, software issue ) and debian 6 aswell the used php version are heavily outdated and unsupported - consider upgrading to at least debian 7 or maybe just stick with php-apc extension.

    Is something like mod_security or php-suhosin enabled/loaded? Does it make a difference if disabled/unloaded?
     
    Last edited: Feb 13, 2016
  13. momo1240

    momo1240 Member

    thank you for your help ztk.me
    I already tried APC (and new version APCu) and installed xcache too, but I noticed that there is no much difference
    so that's why I tried to install opcache (more recent) in order to compare. But of course I dind't run all these cache at the same time.
    Before installing opcache, I uninstalled apc and xcache.
    I think the problem comes from mod_fcgid

    I think I'll keep apcu

    thank you again for your help
     
  14. ztk.me

    ztk.me Active Member

    apcu is for php 5.5+ you probably can safely use apc - if you are using mpm_prefork + fcgi you won't benefit from opcode caching as much as you could if you use mpm_worker because prefork forks multiple threads each with its own (php-)module having its own opcode cache and security wise they can't communicate with each other leading to multiple needs of caching files. The more processes the less the chance having a cache-hit.

    The downside would be you wouldn't be able to use any mod_php / suphp / mod_python and such - depending on your needs just remove then and check mod_fastcgi ( you might need to compile it from source and look for the latest patches which are not included in the packaged source but on the same download page ... well this has been a while I did that, have no link handy :( ).

    In conclusion, consider using mpm_worker + mod_fastcgi + fpm ( might need some hacking / recompiling ), use php-apc for your older php version or .... go debian 7 and then 8 and use mod_fastcgi + worker + php-fpm from the stable repository.

    If you need your old php-version you still can compile it from source + check patches and add it as additional php-version.
     
    momo1240 likes this.

Share This Page