[ helpp ] can't acces ISPConfig via web after reboot/restart

Discussion in 'Installation/Configuration' started by unique_leader, Jul 25, 2008.

  1. unique_leader

    unique_leader New Member

    hellp i can't access ISPConfig via web after i'm restart my server, also with webmin too. why???. pleasee hellp me
     
  2. createch

    createch ISPConfig Developer ISPConfig Developer

    check whether the ISPconfig is running first....

    you may restart the ISPconfig by:
    /etc/rc.d/init.d/ispconfig_server restart

    or (for Suse/debian)
    /etc/init.d/ispconfig_server restart
     
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Are you being asked for a password if you do what createch suggested?
     
  4. unique_leader

    unique_leader New Member

    how to make automatic running after reboot
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Please answer my question first.
     
  6. unique_leader

    unique_leader New Member

    i'm sorry do you mean ISPConfig password?? i don't have trouble in password. createch suggested give me a solution. and now how to make ISPConfing automatic running after reboot
     
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If you want to get help, you will have to answer questions as otherwise you will not get the correct solution for your problem.

    So please answer my question: If you do what createch suggested, are you asked for a password or not?
     
  8. unique_leader

    unique_leader New Member

    i'm not asked for a password
     
  9. createch

    createch ISPConfig Developer ISPConfig Developer

    Dear unique_leader,

    Till's question is highly relevant to your question because in case you are asked for a password then your setting(s) in the RSA key may cause your ISPconfig not able to be restarted without human interaction.

    Now you may try:
    chkconfig --levels 235 ispconfig_server on

    and see whether the ispconfig service can be automatically started....

    Cheers
    Createch
     
  10. unique_leader

    unique_leader New Member


    I try run command that you give. and this the result
    bash: chkconfig: command not found

    my operating system ubuntu 8.04
     
  11. createch

    createch ISPConfig Developer ISPConfig Developer

    For Ubuntu (good to note that you use this distro), you can use update-rc.d to do the job....

    First, write a simple script and put it in the /etc/init.d/ directory. (e.g. "startupispconfig") containing the line:

    /etc/init.d/ispconfig_server start

    Then run the following command to make it executable:
    sudo chmod +x startupispconfig

    Then run:
    sudo update-rc.d startupispconfig defaults

    For further information... please run
    man update-rc.d

    Let us know whether the above works for you.
     
  12. unique_leader

    unique_leader New Member

    not work. are you have any solution?
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    1) Any error message when you run:

    /etc/init.d/ispconfig_server start

    2) Please post the output of:

    netstat -tap | grep ispconfig

    3) Please try:

    sudo update-rc.d ispconfig_server defaults
     
  14. unique_leader

    unique_leader New Member

    this my answer

    1) not error

    2) listen 4825/ispconfig_http

    3) system startup links for /etc/init.d/isp_configserver already exist
     
  15. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    iptables -L
    ?
    Did you disable AppArmor?
    Are there any errors in the error log in /root/ispconfig/httpd/logs?
     

Share This Page