Help with wordpress installation

Discussion in 'General' started by RioSif, Mar 20, 2012.

  1. RioSif

    RioSif Member

    Hello, i have installed ISPconfig 3 using the "The Perfect Server - CentOS 6.2 x86_64 With Apache2 [ISPConfig 3]". I added a new site mysite.org and an other one blog.mysite.org(that's where i want to install wordpress). At the dns i added an A record for blog. The ispconfig default page works there. I created a new datadase with username and password. Added new shell user with which i sshed and wgeted the latest wordpress. Untared at the web dir of my server and edited the wp-config with the database settings. I now browse blog.mysite.org and get a 404.
    What i'm i doing wrong?
    Could anyone help?
    Thanks
     
  2. till

    till Super Moderator

    Please post the exact error message from the error.log of the website. Changes in DNS take up to 24 hours, so it might be that you have not waited long enough after you created or changed the subdomain in dns. Beside that, you should check that you used the correct PHP settings in the site, for cms systems use php mode php-fcgi and the suexec checkbox shold be enabled.
     
  3. RioSif

    RioSif Member

    It was a syntax error at the wp-config. Thanks!
    But one more question: The available modes of php is Fast-CGI, CGI, Mod-PHP and suPHP. Which one should i choose for wordpress and which one is the correct for other cms?
     
  4. till

    till Super Moderator

    You would use php-fcgi for all kind of CMS systems incl. Wordpress, only very low traffic sites should use e.g. php-cgi or suphp. A detailed description of the php modes is also available in the manual.
     

Share This Page