Help with Suhosin patch for php5

Discussion in 'Server Operation' started by robertlouwen, Mar 8, 2010.

  1. robertlouwen

    robertlouwen New Member

    When following the tutorial "Perfect Server Fedora 10" I wanted to harden my php5 with suhosin.
    So I used this tutorial "How To Harden PHP5 With Suhosin On Fedora 7".

    I needed to login as compileuser to run the command rpm -ivh php5.3.0.src.rpm.

    When running rpmbuild -ba php.spec I get the following error:

    1 out of 1 hunk FAILED -- saving rejects to file main/php_logos.c.rej
    error: Bad exit status from /var/tmp/rpm-tmp.QTU1TU (%prep)

    RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.QTU1TU (%prep)

    Any help would be apreciated
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

  3. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    BTW, for Fedora 12, there's a Suhosin package. You can install it as follows:
    Code:
    yum install php-suhosin
    Restart Apache afterwards.
     
  4. robertlouwen

    robertlouwen New Member

    Ofcourse I noticed the tut. "Perfect server fedora 12 with ISPConfig 3x" but I did not read it because I think it is for 64bit machine's only.

    Can I use this tut. for my 32bit machine ?
     
  5. robertlouwen

    robertlouwen New Member

    To be honest, I tried a lot yesterday and I'm not shure but I think that I first tried the patch for php 5.2.10 ( that was installed on my server ) and later I tried php 5.3 so I would end up with an updated php and an patched php.

    Because my server is not a bussiness server ( only me ) I ended with format C:\ and today I started with Debian Lenny
    and so far I like it; memcached/memcache, suhosin are allready included, installing ioncube and zend and mod_geoip was easy.

    So THANK YOU for an other great tutorial
     
  6. robertlouwen

    robertlouwen New Member

    @ Falko, Today I installed Fedora 12 and ISPConfig 3.0.2.

    yum install php-suhosin installed the suhosin extension but did not patch php, so I think I give it an other try to pacht it myself.
     

Share This Page