Help with setup of mailman with virtual domains

Discussion in 'Installation/Configuration' started by mmidgett, Dec 7, 2011.

  1. mmidgett

    mmidgett Member

    I have been trying to get my virtual domains to have their own mailman mailing list. I have mailman setup for my domain main domain and it is working. With ISPconfig 3.04 being able to setup a mailing list I thought it was time give it a try. I can't make the apache2 virtual domains display their own mailman mailing list.

    I am using Ubuntu 10.04

    Here is the link to the FQDN
    Last edited: Dec 7, 2011
  2. cbj4074

    cbj4074 Member HowtoForge Supporter

    It would be helpful if you tell us what steps you've taken and the attendant results.

    You haven't told us anything useful yet...
  3. mmidgett

    mmidgett Member

    The install steps are pretty straight fwd.

    sudo aptitude install mailman

    create the first mail list

    setup the aliases

    I have a working server with ispconfig 3 that was setup using the perfect server setup about 2 years ago. I have roundcube installed for webmail.

    I have tried a few different setups of the vhost and either I break the whole list of virtual domains and then mailman works for the configured domain or i change back the apache2 config and all the sites work.

    In ispconfig the mailing list setup is easy and it is actually working just not the web interface for the virtual host. I did a test subscribe and then sent messages at the email address and got them on the other so the mailing list is working I just need help with Apache2 and Virtual domains. Postfix and mailmain seem to be working fine.
  4. mmidgett

    mmidgett Member

    Please can someone shed some light. I just don't know where to start I have googled and have no idea of what to do.
  5. cbj4074

    cbj4074 Member HowtoForge Supporter

    I haven't used Mailman with ISPConfig, so I'm not familiar with how lists are created, etc.

    I'm willing to install Mailman to help troubleshoot your issue, but the package fails to install on Ubuntu 10.04:

    root@dev:~# apt-get install mailman
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Suggested packages:
    The following NEW packages will be installed:
    0 upgraded, 1 newly installed, 0 to remove and 7 not upgraded.
    Need to get 9677kB of archives.
    After this operation, 44.9MB of additional disk space will be used.
    Get:1 lucid-updates/main mailman 1:2.1.13-1ubuntu0.2 [9677kB]
    Fetched 9677kB in 2s (4753kB/s)
    Preconfiguring packages ...
    Selecting previously deselected package mailman.
    (Reading database ... 59652 files and directories currently installed.)
    Unpacking mailman (from .../mailman_1%3a2.1.13-1ubuntu0.2_amd64.deb) ...
    Setting up mailman (1:2.1.13-1ubuntu0.2) ...
    Looking for enabled languages (this may take some time) ... done.
    Traceback (most recent call last):
      File "/var/lib/mailman/bin/list_lists", line 46, in <module>
        from Mailman import mm_cfg
      File "/var/lib/mailman/Mailman/", line 76
    SyntaxError: invalid syntax
    Installing site language en ............................................ done.
    Traceback (most recent call last):
      File "/usr/lib/mailman/bin/update", line 49, in <module>
        from Mailman import mm_cfg
      File "/var/lib/mailman/Mailman/", line 76
    SyntaxError: invalid syntax
    dpkg: error processing mailman (--configure):
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Obviously, you didn't have this issue. I wonder if it's an issue with Python.
  6. cbj4074

    cbj4074 Member HowtoForge Supporter

    So, for some reason, the package installer interface did not store the language preferences properly.

    When I examined the offending line

    File "/var/lib/mailman/Mailman/", line 76
    there was a missing string for the language. I couldn't even remove the package without fixing the problem. I had to change the line, manually, to:

    # The default language for this server.
    I'll fiddle around a bit now that mailman is functional and configurable via ISPConfig's interface.
  7. cbj4074

    cbj4074 Member HowtoForge Supporter

    Are you using /etc/mailman/apache.conf (or some variant of it) anywhere in your configuration?

    In other words, is your Apache configuration including the above-mentioned file?
  8. mmidgett

    mmidgett Member

    Yrs i tried using hat file to make site wide setups for Apache. It broke my setup. I may have most of it commented out now. its been too long and ive tried to many configurations. I am on the road now so I only have my phone. Tonight when I get settled in I will see what im using. Also for ease of setup I'm using a subdomain of so I could keep from breaking the Apache configurations for the main virtual site. The actual list is working i just can't display the web setup. If you use the command from the email client to setup and register you will be on the list. I can make the web side of the mailing list display but all sites quit working when I do. I'll try to get my configs posted in a bit. Thanks for the help.
  9. cbj4074

    cbj4074 Member HowtoForge Supporter

    I'm curious what, exactly, about the included /etc/mailman/apache.conf file "broke" your setup. When you say "broke", what happened? Apache wouldn't start? Virtual hosts were inaccessible?

    Also, did you un-comment all of the lines relating to VirtualHosts?

    I included this file in my Apache configuration by creating a symbolic link to it in /etc/apache2/conf.d. My sites continue to function as expected and I'm able to access the Mailman interface at any of those domains.

    However, I did not un-comment the section for VirtualHosts. I'm not sure it's necessary.

    That said, you may have a specific reason for wanting to use the VirtualHost directive. Is there some functionality that is missing without it? If so, what?

    Here's the unmodified configuration file, for anyone who may be curious:

    # Sample configuration for Debian mailman with Apache
    # We can find mailman here:
    ScriptAlias /cgi-bin/mailman/ /usr/lib/cgi-bin/mailman/
    # And the public archives:
    Alias /pipermail/ /var/lib/mailman/archives/public/
    # Logos:
    Alias /images/mailman/ /usr/share/images/mailman/
    # Use this if you don't want the "cgi-bin" component in your URL:
    # In case you want to access mailman through a shorter URL you should enable
    # this:
    #ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/
    # In this case you need to set the DEFAULT_URL_PATTERN in
    # /etc/mailman/ to http://%s/mailman/ for the cookie
    # authentication code to work.  Note that you need to change the base
    # URL for all the already-created lists as well.
    <Directory /usr/lib/cgi-bin/mailman/>
        AllowOverride None
        Options ExecCGI
        AddHandler cgi-script .cgi
        Order allow,deny
        Allow from all
    <Directory /var/lib/mailman/archives/public/>
        Options Indexes FollowSymlinks
        AllowOverride None
        Order allow,deny
        Allow from all
    <Directory /usr/share/images/mailman/>
        AllowOverride None
        Order allow,deny
        Allow from all
    ## The following describes how to configure mailman on
    ## a dedicated virtual host, courtesy Marco d'Itri.
    # Add these lines in /etc/mailman/
    #DEFAULT_URL_PATTERN = 'http://%s/'
    #<VirtualHost *>
    #DocumentRoot /var/www/lists
    #ErrorLog /var/log/apache2/lists-error.log
    #CustomLog /var/log/apache2/lists-access.log combined
    #<Directory /var/lib/mailman/archives/>
    #    Options Indexes FollowSymLinks
    #    AllowOverride None
    #Alias /pipermail/ /var/lib/mailman/archives/public/
    #Alias /images/mailman/ /usr/share/images/mailman/
    #ScriptAlias /admin /usr/lib/cgi-bin/mailman/admin
    #ScriptAlias /admindb /usr/lib/cgi-bin/mailman/admindb
    #ScriptAlias /confirm /usr/lib/cgi-bin/mailman/confirm
    #ScriptAlias /create /usr/lib/cgi-bin/mailman/create
    #ScriptAlias /edithtml /usr/lib/cgi-bin/mailman/edithtml
    #ScriptAlias /listinfo /usr/lib/cgi-bin/mailman/listinfo
    #ScriptAlias /options /usr/lib/cgi-bin/mailman/options
    #ScriptAlias /private /usr/lib/cgi-bin/mailman/private
    #ScriptAlias /rmlist /usr/lib/cgi-bin/mailman/rmlist
    #ScriptAlias /roster /usr/lib/cgi-bin/mailman/roster
    #ScriptAlias /subscribe /usr/lib/cgi-bin/mailman/subscribe
    #ScriptAlias /mailman/ /usr/lib/cgi-bin/mailman/
  10. mmidgett

    mmidgett Member

  11. cbj4074

    cbj4074 Member HowtoForge Supporter

    Given this bug that's on the roadmap for ISPConfig 3.0.5, it may be preferable to wait until 3.0.5 is released before throwing additional effort at this:

    If I find time tomorrow, though, I'll see if I can investigate further. It sounds like your issue is different from that mentioned in the bug report, but it seems less than ideal to make Mailman available in a production capacity before the aforementioned issue is resolved.

Share This Page