help with php running as cgi script in Apache opensuse 11.3

Discussion in 'Server Operation' started by wildnux, Sep 13, 2010.

  1. wildnux

    wildnux New Member

    I am trying to run php as cgi script with apache and opensuse 11.3. I disabled the mod_php and installed mod_fcgid, and php-fastcgi, using these instructions here as my guide.

    I have been trying to achieve this, but, somehow it is not working. I can see the page if i have an index.html, but if i have index.php, it downloads it as a file. I really tried to set this thing up for more than 12 hrs now. I am soo frustated. I followed that instruction so many times, changing every thing my little brain could handle, but still not working. Please give me some suggestions.


    my /etc/apache2/vhosts.d/shekhar.conf

    my /srv/www/wrapper/shekhar/php5

    my /etc/apache2/conf.d/mod_fcgid.conf (I uncommented the lines inside the <FilesMatch > Tag., it gave me same result, even after uncommenting the tag.)

    my /etc/apache2/httpd.conf

    please let me know if you know any additional details..
     
  2. wildnux

    wildnux New Member

    After working on it for many hours again, I managed to make it work. But I had to comment the SuexecUserGroup line in /etc/apache2/vhost.d/shekhar.conf file.

    I also uncommented the <FilesMatch > element in mod_fcgid.conf file.

    Now, if I have a file.php, it works. works with https too. But If i rename it to a .cgi file, it just downloads the file. What should I do so that it knows the cgi extension?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    I guess you need to add something like this to your /etc/apache2/conf.d/mod_fcgid.conf:

    Code:
    <FilesMatch "\.cgi$">
        AddHandler fcgid-script .cgi
        FCGIWrapper /srv/www/cgi-bin/php5 .cgi
        Options +ExecCGI
    </FilesMatch>
     

Share This Page