Help with page!

Discussion in 'General' started by Kozley, Jun 4, 2011.

  1. Kozley

    Kozley Member

    ISPConfig 3 is set up and running. When I enter to www.domain.tld and it does only "It works!" and I tired to add files to FTP /web if it correct and it still just "It works!". What do I wrong?? Im using Ubuntu 10.04.2 and ISPConfig
  2. Toucan

    Toucan New Member

    You are getting the default root page.

    When you created the site in the control panel how did you type it in the domain field? or

    It's possible although your browser is landing at the correct server there is no vhost for it.
  3. Kozley

    Kozley Member

    Thank you for reply.

    Both www.domain.tld and don't works. It should be default page by ISPConfig's own, not apache's own.

    I created the site in the control panel I did add new site and dns zone

    Here can you see pics

    Attached Files:

  4. Toucan

    Toucan New Member

    Not 100% sure what's going on here but I think I know, and I can at least give some advice until someone more authoritive is available to step in.

    But, I think what is happening...

    I have a feeling you've not set up glue records for these name servers so when you request a page using them, it just dumps you at the ip of the name server, which in this case happens also to be your web server.

    You could test this out by forgetting the dns for a minute - on your client computer edit the hosts file ( do a quick google search on your OS + hosts file) and add a line:


    reopen your browser and hopefully it will server up your site using the host file instead of dns.

    If that all works, check to make sure you have made the glue records with your server domain.... ie go to your registrar control panel set a glue record up for the name server. It will be something llike set glue record > your.ip...

    If you search on this site for:
    setup ispconfig name server using fasthosts/godaddy/schundtech
    you'll find some guides.

    Hope this helps for now.
  5. Kozley

    Kozley Member

    Okay. I did what u say. I has added to hosts file: intern ipaddress mydomain.tld

    And I don't have godaddy or other, I use swedish registry hosting Loopia and I has check there and I cannot set up glue records there but I did replace dns to loopia's own at ISPConfig control panel. Not successfully :(

    Here can u see the pic of my registry hosting Loopia

    Subdomän= Subdomain
    Typ= Type
    Prio= Priority
    Exportera som zonfil till BIND= Export as zone file to BIND

    Attached Files:

  6. Toucan

    Toucan New Member

    If you've applied the host file to your client then DNS setting shouldn't matter at all as your client machine will be looking straight to the server for site.

    I did notice that you'd put an ip address in the records when creating the site.
    Don't use the ip address this occassion, put *
    Don't put www in front of the domain name, just put

    Make sure all the jobs have completed in the monitor and then try reloading again from a client. machine. Make sure you hit the refresh key so you don't get the old cached page.

    For a clean try;
    Go to site and create a new website.
    It can be (you don't have to have the name registered)
    Take note of the points above. ip * and no www
    You don't need dns
    On a client machine edit the hosts record and add (has to be the one use above of course) and the ip of the server.
    Then try loading in a client.
    You should get the new default page index.html for

    If all that doesn't work then I can help no further.. it's over to an expert here.
  7. Kozley

    Kozley Member


    Thanks you so much! It works now. :D

Share This Page