Help with Mod JK/ Server setup

Discussion in 'Installation/Configuration' started by Rock, Jul 22, 2006.

  1. Rock

    Rock New Member

    Hi,
    I have the ispconfig, tomcat, apache and mod jk installed. Everything is fine when I was running it at home on a internal ip (192.168.1.100) using DHCP.

    I just moved it to office and change it to using statis ip. Now, i cannot acess my web apps on tomcat. This is the debug message from mod_jk.log

    Code:
    [Sun Jul 23 00:49:25 2006] [15212:14016] [debug] init_ws_service::mod_jk.c (531): Service protocol=HTTP/1.1 method=GET host=(null) addrr=220.255.212.224 name=www.kilanaell.com port=80 auth=(null) user=(null) laddr=203.125.112.114 raddr=220.255.212.224
    [Sun Jul 23 00:49:25 2006] [15212:14016] [debug] ajp_get_endpoint::jk_ajp_common.c (2131): acquired connection cache slot=0
    [Sun Jul 23 00:49:25 2006] [15212:14016] [debug] ajp_marshal_into_msgb::jk_ajp_common.c (566): ajp marshaling done
    [Sun Jul 23 00:49:25 2006] [15212:14016] [debug] ajp_service::jk_ajp_common.c (1670): processing with 3 retries
    [Sun Jul 23 00:49:25 2006] [15212:14016] [debug] jk_open_socket::jk_connect.c (328): socket TCP_NODELAY set to On
    [Sun Jul 23 00:49:25 2006] [15212:14016] [debug] jk_open_socket::jk_connect.c (426): trying to connect socket 19 to 192.168.1.100:8009
    [Sun Jul 23 00:52:33 2006] [15212:14016] [info]  jk_open_socket::jk_connect.c (444): connect to 192.168.1.100:8009 failed with errno=110
    [Sun Jul 23 00:52:33 2006] [15212:14016] [info]  ajp_connect_to_endpoint::jk_ajp_common.c (889): Failed opening socket to (192.168.1.100:8009) with (errno=110)
    [Sun Jul 23 00:52:33 2006] [15212:14016] [info]  ajp_send_request::jk_ajp_common.c (1248): Error connecting to the Tomcat process.
    Seems like mod jk is trying to connect to tomcat on 192.168.1.100.

    I checked through http.conf, Vhost_ISPConfig.conf, mod_jk.conf and server.xml, cannot find where in the world does 192.168.1.100 ip comes from.

    Anyone knows what is wrong? Or has any solutions?
    Any comments/ clarifications is really welcomed!! Thanks in advance

    rock
     
    Last edited: Jul 23, 2006
  2. falko

    falko Super Moderator ISPConfig Developer

    You can try to search for 192.168.1.100 in your configuration files with the grep command, e.g.

    Code:
    grep 192.168.1.100 /path/to /file
    or

    Code:
    grep 192.168.1.100 *
     
  3. Rock

    Rock New Member

    Solved!

    I realise that it was the dns that is not correct. Changed it and everything is working fine now.

    It is located under the DNS manager tab in the ISPConfig. There I found the 192.168.1.100.
     
  4. ralvandar

    ralvandar New Member

    We have an instance of Tomcat and Liferay deployed for over 6 months now.
    The website is experiencing poor response time and while debugging, noted the following error in the modjk file as below:

    [Sat Dec 03 08:49:40 2011] [9292:47180921211376] [info] jk_open_socket::jk_connect.c (626): connect to 192.168.1.141:8012 failed (errno=110)
    [Sat Dec 03 08:49:40 2011] [9292:47180921211376] [info] ajp_connect_to_endpoint::jk_ajp_common.c (959): Failed opening socket to (192.168.1.141:8012) (errno=110)
    [Sat Dec 03 08:49:40 2011] [9292:47180921211376] [error] ajp_send_request::jk_ajp_common.c (1578): (liferay1) connecting to backend failed. Tomcat is probably not started or is listening on the wrong port (errno=110)
    [Sat Dec 03 08:49:40 2011] [9292:47180921211376] [info] ajp_service::jk_ajp_common.c (2543): (liferay1) sending request to tomcat failed (recoverable), because of error during request sending (attempt=1)

    The network and sys admin team says that there has been no change.
    What could the issue ?
     

Share This Page