Help with joomla and isp_config

Discussion in 'General' started by sunebeermann, Jan 8, 2007.

  1. sunebeermann

    sunebeermann New Member

    Hi all i used the Joomla howto guide on this site.

    and i said that i sould execute this command to get my folders the right permissons chown -R -v -f www-data:www-data web/* but now i cant remove any files from that domain via FTP what do i do?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    There are two solutions, the simple but not very secure solution is to run:

    chmod 777 web/*

    This sould be ok if you run only your own small websites. The other solution is to use suphp to run the php scripts under the admin user of the website instead of www-data.
  3. sunebeermann

    sunebeermann New Member


    but what is the exact command then?

    chown -R -v -f suphp:suphp web/*

    or ???

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    No, either you use the command I posted above or you will ahve to install and configure suphp on your server. Please use the search function and search for suphp if you dont knwo what it is, there are many threads about this topic.
  5. steve1084

    steve1084 New Member

    reversing the chown for joomla

    When setting up joomla most everyone has the same issue of needing to chown all the joomla files to the domain and then needing to do some server mods to allow ftp to work again. Given that to do the ownership thing we use the command chown -R -v -f www-data:www-data web/* and its very quick and simmple

    chown -R -v -f www-data:www-data web/*

    How do you reverse this command becouse as a very new user of linux I have no idea of what all the commands mean as yet and this would seem to me to be a simmpler sollution to temperarily reverse the chown back to its original state to allow updates etc via ftp and then re-instate the chown after the updates are done. Although suphp is a more permanent fix its not always going to be an option for every person.

    Thanks in advance to anyone who can help as Im sure that this will help lots of people
  6. steve1084

    steve1084 New Member

    Use Joomla explorer

    You can install and use joomla explorer in the backend of joomla to edit and delet and upload all files from within Joomla. Its not as easy to use or as quick as FTP but it does work:)
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    To reveerse the command, you must know to which user and group the files belonged before.

    If this is your first website (ID = 1) and you created a user web1_admin as administrator, the cammand would be:

    chown -R -v -f web1:web1_admin web/*
  8. steve1084

    steve1084 New Member

    Thanks Till

    Thanks Till

    This is a great help, I failed with my first try at using suphp but haven’t given up yet, I am Organising another box to setup and will use it at a testing board and will post my results once I get it all working as the suphp setup guide is incomplete for people like myself with extreme limited knowledge on what I am doing. It might be an idea to add this bit of info about how to reverse the chown to the end of the joomla install guide for noobs like myself along with a quick explain about suphp.

    Thanks again

    What would we do without people like you to help us all, It’s very much appreciated.:D
  9. PermaNoob

    PermaNoob New Member

    I just installed Joomla in a few minutes.

    Noobs like me can avoid the hassles by just unpacking the zip before uploading, then upload the files to your server as the user of the web site where it will be installed. Put them in the web directory if Joomla is going to be the site for your domain.

    I use Winscp for file transfers.

    Make sure php safe mode is off for that site--just uncheck it in the ISP Site basis tab. Also enable ftp for the site.

    Once uploaded, just go to if you installed in the root directory to have Joomla as the main website, then it's easy to follow the install instructions.

    At the end, save the configuration text in a text document as configuration.php and upload that and chmod it to 0744 (in Winscp right click the file and select properties).

    Delete the installation directory.

    Then delete the index.html page so Joomla is loaded when you go to and your good to go!

    I should say I installed the beta 1.5 version, which I believe doesn't have the register globals issue.
    Last edited: Jan 19, 2007
  10. steve1084

    steve1084 New Member

    uploading joomla is not the issue of this thread

    Uploading or Installing or running joomla is not the issue being discussed on this thread, this is a thread about the use of ownership of files by either Joomla or the site user and how they affect Joomla and FTP and the various options we can use to negate the affects of this file ownership issue. This can be achieved by the use of suphp as a permanent solution or by shifting back and forth the ownership of the files as a temperary solution.

    There is a full installation guide for joomla available in the Howtos
  11. PermaNoob

    PermaNoob New Member

    I was pointing out a simpler way to install so that he could avoid the trouble he got into by having to

    chown -R -v -f www-data:www-data web/*

    the Joomla files and the file ownership issue and avoid the complication of suphp.

    There is no ownership issue if you simply upload the files as the site user, and I see that's what now recommends.

    By the way, the thread caption is "Help with joomla and isp-config" and other noobs wanting to install Joomla in ISPconfig are going to see it when they do a search.
    Last edited: Jan 19, 2007
  12. steve1084

    steve1084 New Member

    joomla file ownership

    I don’t agree with you, every thread on this issue I have read shows me that Joomla needs to own its own files in order for it to both read and write to its own files unless you chmod 777 all files and folders which I believe is a very dangerous approach. And this has been my experience from following first the ubuntu 6.10 edge perfect setup and then ispconfig setup and then the Joomla setup guide. If the user remains the owner then joomla can’t be installed properly and won’t run properly until it is given ownership to read and write to its own files and is the reason there are so many threads attempting to deal with this very issue and it needs further clarification on the Joomla install guide so that people know and understand better what they are implementing and how to reverse it and what other options may be available.
  13. PermaNoob

    PermaNoob New Member

    Whatever--I installed Joomla exactly as I said just before I made that post--I uploaded with winscp and didn't change any file permissions except on the configuration.php I uploaded at the end of installation and I chmoded it to 744.

    I've installed Joomla a number of times and never ran into file permission or ownership problems, but I always extracted the files on my computer before uploading--I never uploaded the tar and extracted on the server, and doing that is probably what gets people into trouble.

    This was the beta 1.5. Been a while since I installed an earlier version, but I do remember that I had to change the permissions on some files during installation before on either Joomla or Mambo, but I right click file names in winscp to do it--easy.

    However, I know I never changed any file ownership--don't even know how, lol.

    Try an installation of 1.5 my way and tell me what happens.
    Last edited: Jan 19, 2007
  14. steve1084

    steve1084 New Member

    If it works then this is good

    If what you say is correct then this is good news and yes I will try it. Can you tell us what server your running and what guide you followed and are you using ispconfig and do you have suphp installed or not. Also please show what commands you used etc so it can be used as a guide for everyone.

    As for Joomla 1.5 it should not be used for any production site as it is strictly beta test version only and has at lease 6 major sql and other vulnerabilities at the moment but I know what your getting at is the use of the FTP component. I will hold judgment till I have tryed and tested your methods

  15. PermaNoob

    PermaNoob New Member

    Debian etch with ISPconfig.

    I think I covered the process in my earlier post. I don't have suphp installed. Uncheck php safe mode for the site and enable ftp. Upload with winscp, and follow my earlier instructions for the configuration.php and deleting index.html.

    I also installed directly to the web directory rather than a sub-directory because Joomla will be the site for that domain.

    I just followed the Joomla instructions which you see after uploading the files and going to, which are quite easy.

    Yes, Joomla 1.5 is beta -- I'm testing and learning it for now. It's a major change and you won't be able to upgrade from earlier versions, though you will be able to migrate data.
    Last edited: Jan 19, 2007
  16. PermaNoob

    PermaNoob New Member

    I guess the ftp layer is what makes it work--found this on the Joomla site:

  17. steve1084

    steve1084 New Member

    Not a complete failure but not a success either

    Ok I downloaded winscp and tried your methodology on my ubuntu+ispconfig setup and for me it did not work. I was unable to get all the files to a state where Joomla could write to them without changing the ownership. This applies to both 1.0 and 1.5 versions of Joomla. However I was able to get Joomla 1.5 to install without changing the file ownership up front. After the install of 1.5 I then tried to make modifications and this is when I started to run into problems because Joomla did not have permission to write to the files and a number of key module folders remained un-writable to Joomla.

    When I installed Joomla 1.5 all files remained as owned by the user ie web_user and Joomla was able to do many of the things it needs to do but not all. It was only when I then changed ownership over to www-data that Joomla gained full write and delete capabilities but yes the ftp component then drops out from 1.5 so Not a complete failure but not a success either.

    Joomla 1.0 would not install or function properly until file ownership was changed. winscp is simply a secure ftp component but it may be that you have certain parameters setup or are using it with different settings to me so Maybe I need more info. I will say that I had not used winscp previously and after using it I will now continue to use it as I liked some of the features it offered very much so thanks for introducing me to winscp.:)

    The bottom line is that Joomla needs full write and delete functionality to operate without error and with or without the FTP functionality of 1.5 on a properly secured Linux box there seems to be no shortcuts. I would however like somebody else to try your method and provide there experience as I am a relative newcomer to Linux but have been using Joomla and installing etc Joomla/mambo sites for about 2 years now. It may be that with the release of Joomla 1.5 that your method might become a real option, fingers crossed.
  18. PermaNoob

    PermaNoob New Member

    I was playing with Joomla yesterday and the only thing that didn't work so far was the the news link which loads news from Joomla and other sources, and I had to change the cache directory to 777, but I haven't tried much yet.

    I had no problem changing front page stories.

    By the way, I inserted video on the front page by using the link text from YouTube and editing the html in story 2 to insert it, in case that would be useful for you.
  19. Webspot

    Webspot New Member

    Permanoob the issue that steve1084 is pointing out is an existing one in both versions of joomla. I have been runing into the same issues as well. Perhaps you mis understood what is conflicting. By default the apache has the right permision which joomla utilizes for its install. It has nothing to do with file permissions but more to do with Onwership of the files. (which can be seen in ftp select the owner tab)

    For example if i wanted to edit, delete, or rename an original file from within joomla which was uploaded during installation the system would not let me.

    As the owner is www-data and not the administrator of the website.
    This ofcourse is a huge problem if you are constantly using many different modules plugins and components that might require some manual editing by you so they can work to the best possible specifications.

    An example of that is removing a line of text from a mambot which references a style sheet you can not use the classical method of down load file and edit and simply replace in ftp.

    Ive read a few posts on this suphp but none of them are comforting enough for me to attempt.

    Permanoob if you could check if you have 2 different type owners in an ftp connection would be great. If you do then you will experience the same issues if you don't on the other hand then me, Steve and another 20 or so people mentioning this problem got the short end of the stick.

    Steve drop us a line if you come around to installing suphp successfully
    Last edited: Jan 20, 2007
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Here is a detailed SuPHP guide:

    SuPHP installation is easy if you follow the howto. Dont forget that only poeple with problems during installation post here in the forums and not the hundreds or thousands of successful installations.

Share This Page