Help with ispconfig 3 perfect ubuntu and urchin

Discussion in 'HOWTO-Related Questions' started by dxh, Dec 17, 2009.

  1. dxh

    dxh New Member

    I am trying to set up urchin profiles for the sites I have hosted with my ispconfig server. The main thing I need to do is change log settings.
    This line was added to apache2/apche2.conf file:
    LogFormat "%v 135594252 t \"r\" >s b \"{Referer}i\" \"{User-Agent}i\" \"{Cookie}i\"" special

    but I can't find the vhost info.

    From the urchin docs:
    Examine the <VirtualHost> entry you wish to enable this logging for.
    Insert a # in front of any existing TransferLog or CustomLog entries to deactivate it/them, and insert the following (editing the pathname appropriately for your environment):

    CustomLog /www/serverlogs/www.urchin.com_cookie_log special

    My question is where can I find the site specific logs?
    What file has the log config for the individual sites.

    I am sorry if this is basic. I am still new to the linux world.
    FYI Urchin is installed on a win2k3 machine.
    Thanks for reading

    Dave
     
    Last edited: Dec 17, 2009
  2. dxh

    dxh New Member

    Does anyone have any experience setting up urchin profiles for sites running under ispconfig3? I really just need to customize log format and location for all the vhosts (sites) that are running on my ispconfig machine. Here is what google says:
     
  3. falko

    falko Super Moderator ISPConfig Developer

    I've never worked with Urchin... :(
     
  4. bnight

    bnight New Member

    dxh

    Here is what I done to get this working:

    I edit /etc/apache2/apache2.conf

    And add this line:

    LogFormat "%h %v %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" \"%{Cookie}i\"" urchin

    Above:

    # Include the virtual host configurations:

    So the /etc/apache2/apache2.conf looks like this:

    LogFormat "%h %v %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" \"%{Cookie}i\"" urchin

    # Include the virtual host configurations:
    Include /etc/apache2/sites-enabled/

    Next I go to the ISPConfig 3 panel and from tab sites i chose with site i want to edit:

    I chose Options tab

    And add this in the text box Apache directives:

    CustomLog /var/log/ispconfig/httpd/domain.com/urchin.log urchin

    And then hit Save button.

    Now my log in the urchin format is /var/log/ispconfig/httpd/domain.com/urchin.log

    Then

    chmod 755 /var/log/ispconfig/httpd/bnight.com/

    So the urchin daemon can read the log.

    That`s it.

    I hope that this will work for you.
     
    Last edited: Dec 22, 2009
  5. dxh

    dxh New Member

    You are my personal savior this holiday season :)

    This worked like a charm.
     
    Last edited: Dec 23, 2009
  6. dxh

    dxh New Member

    darn, I was adding an apache directive to another site in ispconfig and I made a typo. Hitting save seemed to kill apache and now I get a fail when trying to restart it.
    What did I do? or better
    Is there a way to fix it.

    Thanks
     
  7. dxh

    dxh New Member

    For now I reverted to a snapshot. Not sure what I did.
     
  8. bnight

    bnight New Member

    OK so here is what you can do to fix this one:

    First remove the lines from ISPConfig 3 options and hit save.

    Then if the apache2 don`t start

    Edit: /etc/apache2/sites-available/domain.com.vhost

    And remove the lines that you add with the typo error.

    Then restart apache.

    /etc/init.d/apache2 restart

    And this is it.
     
  9. dxh

    dxh New Member

    Thanks for all your help. I am working and urchin profiles are running.
    Just out of curiosity: what log settings do you use for the apache logs in urchin?
    I use w3c for my IIS sites, and for now I am using auto for apache sites. Not sure if there is a better choice.
    Either way, thank you for all your help in getting this working. Places like this make moving to open source a reality for the folks like me
     
  10. bnight

    bnight New Member

    Dave i don`t use Urchin just setup one on some test environment to see how it works and help you. I use auto for the logs from apache and it works like a charm.

    Have a nice christmas,

    Hristofor
     
  11. dxh

    dxh New Member

    I am using auto with success.
    Thanks for going through all this to help.
     

Share This Page