Help with DCHP server

Discussion in 'HOWTO-Related Questions' started by DangerIsGo, Jun 29, 2008.

  1. DangerIsGo

    DangerIsGo New Member

    Here: http://www.howtoforge.com/ubuntu6.10_firewall_gateway_p9

    Is stated on how to setup a DHCP server with a ShoreWall Firewall. I got the firewall working but the DHCP server refuses to start. I find this in the syslog:

    Jun 29 01:19:09 firewall dhcpd: Internet Systems Consortium DHCP Server V3.0.4
    Jun 29 01:19:09 firewall dhcpd: Copyright 2004-2006 Internet Systems Consortium.
    Jun 29 01:19:09 firewall dhcpd: All rights reserved.
    Jun 29 01:19:09 firewall dhcpd: For info, please visit http://www.isc.org/sw/dhcp/
    Jun 29 01:19:09 firewall dhcpd: Wrote 0 leases to leases file.
    Jun 29 01:19:09 firewall dhcpd:
    Jun 29 01:19:09 firewall dhcpd: No subnet declaration for eth0 (169.254.9.73).
    Jun 29 01:19:09 firewall dhcpd: ** Ignoring requests on eth0. If this is not what
    Jun 29 01:19:09 firewall dhcpd: you want, please write a subnet declaration
    Jun 29 01:19:09 firewall dhcpd: in your dhcpd.conf file for the network segment
    Jun 29 01:19:09 firewall dhcpd: to which interface eth0 is attached. **
    Jun 29 01:19:09 firewall dhcpd:
    Jun 29 01:19:09 firewall dhcpd:
    Jun 29 01:19:09 firewall dhcpd: Not configured to listen on any interfaces!

    While this is my dhcpd.conf file:

    subnet 192.168.1.0 netmask 255.255.255.0 {
    range 192.168.1.100 192.168.1.130;
    option routers 192.168.1.1;
    default-lease-time 14400;
    max-lease-time 14400;
    option broadcast-address 192.168.1.255;
    }

    And this is my dhcp3-server file:

    INTERFACES=eth0

    Basically, eth0 is the internal NIC which will be the DHCP server to my LAN while eth1 is the NIC connected to the DSL modem, working in conjunction with PPPoEconf. So in turn, ppp0 is the WAN. Does anyone know what this message means and how would I go about fixing it? Ive searched forums and guides for the past few hours and found no fix. Thanks.
     
  2. topdog

    topdog Active Member HowtoForge Supporter

    You need to have an interface that is in the same range as the subnet declaration in your dhcpd.conf
     
  3. DangerIsGo

    DangerIsGo New Member

    I do. I statically set eth0 to 192.168.1.1/255.255.255.0/no gateway.
     
  4. topdog

    topdog Active Member HowtoForge Supporter

    You possibly did not apply,
    Code:
     No subnet declaration for eth0 (169.254.9.73).
    Check the output of
    Code:
    ifconfig
     
  5. DangerIsGo

    DangerIsGo New Member

    Thanks for responding. I double checked everything and went to ifconfig and it said 192.168.1.1/255.255.255.0 and when I went to start DHCP server, it worked. How? I have no idea. Last night i spent hours doing the same thing I JUST did, and it wouldn't work. Thanks.

    ONe more thing. My shorewall, My firewall can access the internet, but anything on my LAN cannot. I have, temporarily, allowed everything in the policy, just to test, and still, the LAN cannot access the internet. My policy is as follows:

    #
    # Policies for traffic originating from the local LAN (loc)
    #
    # If you want to force clients to access the Internet via a proxy server
    # on your firewall, change the loc to net policy to REJECT info.
    loc net ACCEPT
    loc $FW ACCEPT
    loc all REJECT info

    #
    # Policies for traffic originating from the firewall ($FW)
    #
    # If you want open access to the Internet from your firewall, change the
    # $FW to net policy to ACCEPT and remove the 'info' LOG LEVEL.
    # This may be useful if you run a proxy server on the firewall.
    $FW net ACCEPT
    $FW loc ACCEPT
    $FW all REJECT info

    #
    # Policies for traffic originating from the Internet zone (net)
    #
    net $FW DROP info
    net loc DROP info
    net all DROP info

    # THE FOLLOWING POLICY MUST BE LAST
    all all REJECT info

    #LAST LINE -- ADD YOUR ENTRIES ABOVE THIS LINE -- DO NOT REMOVE

    I can ping eth0 from a comp inside the LAN as well as accessing webmin, but no internet access. Any ideas would be greatly appreciated. I have setup eth0 as loc in the interfaces for shorewall.

    Edit: I found the DNS servers on my router (the WAN port connected to eth0) were to be 0.0.0.0, so i set them to first the same address as eth0, and then to the 2 verizon DNS server. Neither allowed internet access on my LAN comp.


    Edit 2: This is my new dhcpd.conf file:
    ddns-update-style interim;
    ignore client-updates;

    subnet 192.168.1.0 netmask 255.255.255.0 {
    option routers 192.168.1.1;
    option subnet-mask 255.255.255.0;
    option domain-name-servers ##.###.#.##;
    option ip-forwarding on;
    range dynamic-bootp 192.168.1.100 192.168.1.254;
    default-lease-time 21600;
    max-lease-time 43200;
    }
     
    Last edited: Jun 29, 2008

Share This Page