Help with apache owner problem!

Discussion in 'Installation/Configuration' started by comtjfnon, Dec 31, 2005.

  1. comtjfnon

    comtjfnon New Member

    Hi!
    I've installed Joomla CMS, and have some trouble with my ISP. Using SCP, I see that a lot of my files have "apache" as owner, in stead of my username. This causes problems for me. For Ex, when I'm customizing a template, apache takes ownership when saving and my site will not work.

    Is there someone out there, who could give me a quick "howto" I can send to my ISP? I've read something about having phpscripts run as owner, but how to configure this? And does this cause problems for my ISP?

    Thank you !
    And I wish you a happy new Year from Norway!
     
  2. till

    till Super Moderator

    If PHP scripts shall run under the web administrator user, suexec must be enabled in ISPCOnfig and PHP must be run as CGI not mod_php.

    You can solve your problems also by making your template files world readable and writable.
     
  3. comtjfnon

    comtjfnon New Member

    Hi again!

    Thanks for quick reply! I shall contact my ISP with this information. My problem is when I do modifications, apache takes ownership and then I can't chmod them (writeble).

    One of my biggest problems, is when I try to post news in Joomla or Wordpress, the text gets duplicated. Why I don't know, but wonder if it has something to do with the server setup. Have you any clue?
     
  4. falko

    falko Super Moderator

    I guess this means it isn't your server, and you don't have root access to make the suggested changes?
     
  5. comtjfnon

    comtjfnon New Member

    Root access

    Hi!
    No, I don't have root access, but I've spoken to my ISP, and they will try to help me if I can come up with some solutions that wouldn't put securiy at risk..
     
  6. till

    till Super Moderator

  7. comtjfnon

    comtjfnon New Member

    Sorry to bug you, but..

    I would appreciate you're comment on this!

    My problem is, like I told you
    "One of my biggest problems, is when I try to post news in Joomla or Wordpress, the text gets duplicated. Why I don't know, but wonder if it has something to do with the server setup. Have you any clue?"

    Today, I opened phpmyadmin and looked at the database. I then tried to copy into jos_content the html code I wanted to post (I first wrote my article in Joomla, pressed the HTML button in the wysiwyg and copied it bedfore i saved - then it get messed up). When I looked at it in Joomla, it had duplicated. Could this then be a MySQL problem? My ISP is running MySQL 3.23.54..

    The phpinfo file you can see here. Something wrong?

    Regarding apache owner, my ISP shall test your config and get back to me! He agreed on everything you wrote, but had to check locally first!
     
    Last edited: Jan 4, 2006
  8. falko

    falko Super Moderator

    The output of phpinfo(); looks ok.
    I don't think it's a problem with MySQL; I guess it's rather some kind of misconfiguration in Joomla. Maybe you can debug the scripts by putting some echo or die() statements into them.
     
  9. comtjfnon

    comtjfnon New Member

    I would agree with you if it haven't been that I get the same problems when I install simular programs like WordPress.. Debug, debug.. Hopefully my next reply will be an answer..
     

Share This Page