HELP! Upgraded from to & Apache fails to start

Discussion in 'Installation/Configuration' started by snowfly, Jan 26, 2012.

  1. snowfly

    snowfly Member

    I just updated ISPConfig from to (debian lenny system)
    Using the command

    This has worked fine in the past, but now for the master server, apache now fails to start!!! :(

    /var/log/apache/error.log reports:
    [Thu Jan 26 20:55:56 2012] [error] Server should be SSL-aware but has no certificate configured [Hint: SSLCertificateFile] ((null):0)

    All paths used by SSLCertificateFile are correct.

    As a test, I commented out all SSL directives in any apache config site, tried to restart apache, but the same problem, same error as above :(

    Please help?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I havent seen that error yet on a server, so it can be that it is not directly related with the ispconfig update and just a coincident e.g. when the apache config was modified before or a ssl file was deleted and apache was not restarted afterwards, so that the problem was not "visible" until the ispconfig updater restarted apache. The only apache files that get changed during update are the ispconfig.conf and ispconfig.vhost files in /etc/pache2/sites-available. Try to comment out the ssl directives in the ispconfig.vhost file, if you havent done that yet.

    you might also want to check with:

    ps aux | grep apache

    if there are any hanging apache processes, as apache can fail to restart or load its config when there are zombie processes left.
  3. snowfly

    snowfly Member

    Yes it seems to be a coincidence...

    Tried all of the following below but still no luck, same error.

    1. ps aux | grep apache = no processes
    2. Disabled all SSL sites, checked with: grep SSL /etc/apache2/sites-enabled/* = no results
    3. Rebooted server = no change

    Any other suggestions?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to disable ssl with:

    a2dismod ssl

    and try to restart then. Afterwards try to reenable it with

    a2enmod ssl

    Then you can try to run a configtest with:

    apache2ctl configtest

    If this all does not help, you can try a reinstall of the apache package with:

    apt-get install --reinstall apache2 apache2.2-common apache2-mpm-prefork
  5. snowfly

    snowfly Member

    Interestingly, if I disable SSL completely, apache is able to start.
    Although completely not ideal (as I have a couple of SSL sites on this server), the other non-SSL sites can at least run for now, until a fix is found.

    a2dismod ssl
    apache2ctl start

    Working... without ssl
  6. snowfly

    snowfly Member

    After disabling ssl (a2dismod ssl), running apache2ctl configtest gave this:
    Syntax OK

    Tried reinstalling apache packages, no difference.
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, thats at least a starting point so we know that its really a ssl problem, as error messages can be misleading sometimes :)

    Maybe you should do a more broader grep with:

    grep SSL /etc/apache2/

    to see all ssl related settings in other apache files and try commenting them out with a # in front of the lines, so we can try tolower down which config line is causing this.
  8. snowfly

    snowfly Member

    Ok I have removed all symlinks from /etc/apache2/sites-enabled/ , except for:

    After enabling ssl again (a2enmod ssl), and restarting apache, apache starts fine, and works fine.

    So now I am going through each site, enabling one by one, and restarting apache.
    Going ok so far...
  9. snowfly

    snowfly Member

    Found the problem site file.
    It contained:
    <VirtualHost *:443>
    Redirect permanent / https://yy.yyyyyyy.yyy/o/

    The purpose of this was to redirect an old URL to a new site.
    Can do without it for now, as everything now works with it not enabled :)

    Problem solved, thanks for your help.

Share This Page