[help] ubuntu 15.04 can send mail but cannot receive mail

Discussion in 'General' started by herman123, Jul 25, 2017.

  1. herman123

    herman123 New Member

    hi everyone, i'm newbie at ispconfig 3 i have no idea why cannot receive mail
    but i can sending mail, what should i do?
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    "receiving" involves mail being delivered on your server, eg. from other mail servers on the internet, as well as your mail client connecting to the pop/imap server and downloading messages - which piece isn't working? Eg. if you send email from gmail or somewhere, what happens, it bounces or it seems to work buy you don't receive it when checking? (check your mail.log to see what happens there) When your mail client (pop or imap) tries to check mail, do you get any errors? If you send a message to yourself so that it never leaves your server, are you able to receive that?
     
  3. loonatik

    loonatik New Member HowtoForge Supporter

    Did you set up an MX record with your domain registrar?
     
  4. herman123

    herman123 New Member

    i can do sending mail to other server (yahoo,googe,etc) but when im tries replying that messages, i got a reply, "undelivered mail returned to sender"
    and this my mail.log
    this is my records at ispconfig
    did you mean i must registering the cname and mx to my domain manager?
     
  5. Tuumke

    Tuumke Member

    Code:
    tijmen@LT53039:~$ dig mx domainku.com
    ; <<>> DiG 9.9.5-3ubuntu0.14-Ubuntu <<>> mx domainku.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28906
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;domainku.com.  IN  MX
    ;; ANSWER SECTION:
    domainku.com.  3600  IN  MX  0 localhost.
    You need to setup mx records that point to your e-mail server, not localhost. You are now telling everyone to look at localhost. Meaning that you are telling them to look at themselfs...

    It should look like this:
    Code:
    tijmen@LT53039:~$ dig mx tsictdiensten.nl
    
    ; <<>> DiG 9.9.5-3ubuntu0.14-Ubuntu <<>> mx tsictdiensten.nl
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 58936
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;tsictdiensten.nl.  IN  MX
    
    ;; ANSWER SECTION:
    tsictdiensten.nl.  3600  IN  MX  10 mail.tsictdiensten.nl.
    
    ;; Query time: 38 msec
    ;; SERVER: 89.101.251.228#53(89.101.251.228)
    ;; WHEN: Wed Jul 26 07:03:06 DST 2017
    ;; MSG SIZE  rcvd: 66
    
     
  6. herman123

    herman123 New Member

    i just knew,thank you but, i don't know how to edit the mx should point to ip, not localhost
     
  7. Tuumke

    Tuumke Member

    At your domain registrar, where you bought domain, you should have control panel with DNS management.
    There you can edit DNS records.
     
  8. herman123

    herman123 New Member

    such like a registrar name server?
    thank's mate, i'll trying
     
  9. herman123

    herman123 New Member

    i have trying, but still not work mate
    this result of my dig mx
     
  10. Tuumke

    Tuumke Member

    That should be fine.
    Though, i do see something strange:
    Code:
    ; <<>> DiG 9.9.5-3ubuntu0.15-Ubuntu <<>> mail.creativauz.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 48837
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1
    
    ;; OPT PSEUDOSECTION:
    ; EDNS: version: 0, flags:; udp: 4096
    ;; QUESTION SECTION:
    ;mail.creativauz.com.           IN      A
    
    ;; ANSWER SECTION:
    mail.creativauz.com.    3600    IN      CNAME   mail.creativauz.com.creativauz.com.
    mail.creativauz.com.creativauz.com. 3600 IN A   36.66.94.133
    
    ;; Query time: 414 msec
    ;; SERVER: 89.101.251.228#53(89.101.251.228)
    ;; WHEN: Wed Jul 26 08:50:23 DST 2017
    ;; MSG SIZE  rcvd: 98
    mail.creativauz.com is pointing to a cname which is 2x the domain: mail.creativauz.com.creativauz.com ?
    mail.creativeauz.com should be poiting to where the cname is pointing:36.66.94.133

    So results should be:
    mail.creativauz.com. 3600 IN A 36.66.94.133
    Remove the cname and make mail.creativauz.com an A record poiting to ip adress.
     
  11. herman123

    herman123 New Member

    did this result has correct ?
    mail.creativauz.com. 3600 IN A 36.66.94.133
    but i try to sending mail still not found on inbox roundcube

    and this reply
     
  12. Tuumke

    Tuumke Member

    Just send you a test mail at admin@creativauz.com
    Have not received any error messages. Let me know if you got it.
     
    Last edited: Jul 26, 2017
  13. Jesse Norell

    Jesse Norell Well-Known Member

    In addition to your DNS problems, that indicates amavis is not running - you might try restarting it and check the log for errors if it isn't running afterwards.
     
  14. herman123

    herman123 New Member

    i've got this reply

    i have restarting the amavis and this amavis's status

     
  15. Tuumke

    Tuumke Member

    So, you cannot send a reply? Is that what you are asaying?
     
  16. herman123

    herman123 New Member

    yaaa, cannot send reply from another server to admin@creativauz.com
     
  17. Tuumke

    Tuumke Member

    What is domainku.com?
    Because that is what you were talking about earlier? MX is still pointing to localhost.

    Please post output of:
    Code:
    uname -a
    cat /var/log/mail.log
    cat /etc/postifx/main.cf
    cat /etc/hostname
     
  18. herman123

    herman123 New Member

    nothing mate, i am using creativauz.com
    output uname -a
    too long output , then i use tail -f n10 /var/log/mail.log, this output
     
  19. herman123

    herman123 New Member

    output cat /etc/postfix/main.cf
    this output from cat /etc/hostname
    creativauz.com
     
  20. Tuumke

    Tuumke Member

    in the postfix, myhostname should be mail.creativauz.com i think....
    WHich guide did you follow?
    If you run a multi server setup, hostname should be full fqdn , web.example.com, db.exampble.com.
    If its single server, it sould be web.example.com or panel.example.com
     
    Last edited: Jul 29, 2017

Share This Page