Help....Sound

Discussion in 'Programming/Scripts' started by sbovisjb1, Mar 31, 2006.

  1. sbovisjb1

    sbovisjb1 New Member HowtoForge Supporter ISPConfig Developer

    I would like to know what i should do to get sound working on fedora core 4. I have a HP nx6110. I dont know what the brand of card is, but im assuming that its one of the stock defaults (everything else registered A OK) http://www.pcmall.com/pcmall/shop/detail~dpno~200292.asp. But the site didnt tell me my sound card at all. Any comments or help on what you did or what i should do would help... even if you dont have the same model laptop... thanks.
     
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you have ALSA installed?
    Anything in the logs?
     
  3. sbovisjb1

    sbovisjb1 New Member HowtoForge Supporter ISPConfig Developer

    Im doing that right now.

    Im busy installing ALSA (VERY cool) and im confused with these two steps


    7) Edit your kernel module config (either /etc/modprobe.conf or
    /etc/modules.conf, depending on the kernel version). If you are not
    sure, what to do, you may try the alsaconf script available in
    the alsa-utils package.

    8) Run 'modprobe snd-xxxx' where xxxx is the name of your card.
    Note: All ALSA ISA drivers support ISA PnP natively, so you don't need
    isapnptools any more. Don't use both together. It will
    conflict. For disabling the ALSA ISA PnP support, specify
    --with-isapnp=no configure switch.
     
  4. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Run
    Code:
    modprobe snd-xxxx
    (replace xxxx appropriately) and then add snd-xxxx to /etc/modules so that the module gets loaded at boot time. I'm not quite sure if step 7 is needed anymore then...
     
  5. sbovisjb1

    sbovisjb1 New Member HowtoForge Supporter ISPConfig Developer

    Thanks

    Thank you very much... I am quite proud to say that this is an amasing project. Hmmm its good ;) And if i have any more problems ill let you know.
     
  6. sbovisjb1

    sbovisjb1 New Member HowtoForge Supporter ISPConfig Developer

    When my machine first started, all external audio was muted. To unmute it, run alsamixer in a terminal, hit right-arrow until you get to item "External Amplifier", and type "m" to toggle the mute setting. Also, bring up the Sound & Video -> Volume Control application and check for proper settings.
     

Share This Page