HELP! Site is suddenly down

Discussion in 'Installation/Configuration' started by codydwilson, Oct 30, 2008.

  1. codydwilson

    codydwilson New Member

    Yes

    i also tried making a new site to see if that didn't change some setting around, same thing, all TLD point to the apache default page still.
     
  2. _X_

    _X_ New Member

  3. _X_

    _X_ New Member

    take a good look at all log files in /var/log/ and search for ony error is the last advice i have :(
     
  4. _X_

    _X_ New Member

    do you have at the end of file /etc/apache2/apache2.conf

    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
     
  5. _X_

    _X_ New Member

  6. codydwilson

    codydwilson New Member

    Thanks for the continuing help _X_,

    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf is at the bottom of apache2.conf

    is there anyway it could be a problem with permissions? When i was setting up Joomla i had to change a bunch of permissions. Just a thought.

    Also:

    Code:
     * Restarting web server apache2
    [Mon Nov 03 11:44:10 2008] [warn] NameVirtualHost 69.146.169.180:80 has no VirtualHosts
    [Mon Nov 03 11:44:20 2008] [warn] NameVirtualHost 69.146.169.180:80 has no VirtualHosts
       ...done.
    
    that doesn't seem good...
     
    Last edited: Nov 3, 2008
  7. _X_

    _X_ New Member

  8. _X_

    _X_ New Member

    does:

    httpd -t

    gives:

    Syntax OK
     
  9. _X_

    _X_ New Member

    does:

    apache2 -t

    gives:

    Syntax OK
     
  10. _X_

    _X_ New Member

    one more idea:

    in your /etc/apache2/vhosts/Vhosts_ispconfig.conf

    replace every:
    69.146.169.180:80
    with:
    *:80
    (there are 3 changes to be done)
    after that:
    /etc/init.d/apache2 restart
     
    Last edited: Nov 4, 2008
  11. codydwilson

    codydwilson New Member

    Code:
    [Wed Nov 05 21:36:03 2008] [warn] NameVirtualHost 69.146.169.180:80 has no VirtualHosts
    Syntax OK
    [email protected]:~# apache2 -t
    [Wed Nov 05 21:36:08 2008] [warn] NameVirtualHost 69.146.169.180:80 has no VirtualHosts
    Syntax OK
    
    had to change the user and group names to www-data in apache2.conf, but how it's going back ok.




    GREAT SUCCESS:

    After changing ip address to * got this on the restart

    Code:
    [email protected]:~# /etc/init.d/apache2 restart
     * Restarting web server apache2
    [Wed Nov 05 21:49:01 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
    [Wed Nov 05 21:49:11 2008] [warn] NameVirtualHost *:80 has no VirtualHosts
       ...done.
    
    Now shared ip page coming up! never been so excited to see that page!

    Now what.....lol


    OK UPDATE #2

    www.grizzlypaintball.com WORKS!!!!!!!!

    not grizzlypaintball.com so any idea on that, i can't thank you enough for your help _X_
     
    Last edited: Nov 6, 2008
  12. _X_

    _X_ New Member

    that should be fixed if you add in ISPConfig admin:
    ISP Manager/Sites/grizzlypaintball.com(for example)>Co Domains
    |New|
    Hostname: leave blank
    Domain: grizzlypaintball.com
    |Save|
     
  13. _X_

    _X_ New Member

    Interesting fact is that ping 69.146.169.180 gives Request time out. and same result goes for ping www.grizzlypaintball.com.
     
  14. _X_

    _X_ New Member

    also no dns and mx record can be found for grizzlypaintball.com
     
  15. codydwilson

    codydwilson New Member

    Not sure what to say about that. Using godaddy as dns, feel like i don't need to deal with that on top of everything else. The co-domain worked great and everything is serving as it should so i think it's safe to put a SOLVED on this case. Thanks agian _X_!
     
  16. _X_

    _X_ New Member

    :) you are using godaddy :) you should say that in the first place ...
     
  17. _X_

    _X_ New Member

  18. _X_

    _X_ New Member

    you can try to enter godaddy NameServers as NameServers for ISPConfig if godaddy have those settings ...

    http://help.godaddy.com/topic/307/article/664

    in ISPConfig:

    Management/Server/Settings/DNS/
    Default Ns1: ns1.secureserver.net < example
    Default Ns2: ns2.secureserver.net < example

    after that you can change back *.80 to 69.146.169.180:80 in Vhosts_ispconfig.conf and restart apache
    /etc/init.d/apache2 restart

    and see if that works
     
  19. codydwilson

    codydwilson New Member

    working great thanks agian!
     

Share This Page