HELP! Site is suddenly down

Discussion in 'Installation/Configuration' started by codydwilson, Oct 30, 2008.

  1. codydwilson

    codydwilson New Member

    This morning i checked my site, grizzlypaintball.com, and the only thing that came up was "it works" on the page. I tracked it down to the index.html file in /var/www/ but have no idea why it's there, or why it's now coming up. Had been working perfectly for a long time now. Any suggestions would be great as this site is used for my business and i need to get it back up and running soon.


    Thanks,

    Cody
     
  2. _X_

    _X_ New Member

    that is default apache index.html that you got there.

    check what IP has your site under ISPConfig

    did you upgrade something lastnight?
     
  3. codydwilson

    codydwilson New Member

    both the server and the site are set to my external ip, i am behind a router but that was all properly forwarded and whatnot. I didn't upgrade anything on the server, only made adjustments to the website.
     
  4. _X_

    _X_ New Member

    well something has changed and you see default apache index.html like there are no virtualhosts defined

    see what is in /etc/apache2/vhosts/Vhosts_ispconfig.conf

    that file is created/modified by ISPConfig so don't change anything if you don't know what you are doing.
    Vhosts_ispconfig.conf can be recreated by changing something in one web site in ISPConfig (like SSL) , do Save, change the same option for the same site back, Save again to take it to previous state.
     
    Last edited: Oct 31, 2008
  5. codydwilson

    codydwilson New Member

    Here's the output from /etc/apache2/vhosts/Vhosts_ispconfig.conf. Looks fine to me but i really don't have an eye for this stuff. The only thing that i can think of that i did, was download a backup for the site from ISPConfig, doubt it caused this problem since it worked fine for a while afterwards.


    Code:
    ####################################
    # ISPConfig vHost Configuration File
    #         Version 1.0
    #
    ###################################
    #
    NameVirtualHost 69.146.169.180:80
    <VirtualHost 69.146.169.180:80>
      ServerName localhost
      ServerAdmin [email protected]
      DocumentRoot /var/www/sharedip
      <IfModule mod_rewrite.c>
        RewriteEngine on
        RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
        RewriteRule .* - [F]
      </IfModule>
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: [url]www.grizzlypaintball.com:80[/url]
    ######################################
    
    #
    #
    <VirtualHost 69.146.169.180:80>
    ServerName [url]www.grizzlypaintball.com:80[/url]
    ServerAdmin [email][email protected][/email]
    DocumentRoot /var/www/web1/web
    DirectoryIndex index.php index.php5 index.php4 index.php3 index.shtml index.cgi 
    index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web1/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php3>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php4>
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    <Files *.php5>
    
        SetOutputFilter PHP
        SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    Alias /error/ "/var/www/web1/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
    <IfModule mod_rewrite.c>
      RewriteEngine on
      RewriteCond %{REQUEST_METHOD} ^(TRACE|TRACK)
      RewriteRule .* - [F]
    </IfModule>
    </VirtualHost>
    #
    #
    #
    
     
  6. _X_

    _X_ New Member

    few more question:
    - is mail working
    - is ftp working
    - are there files in /var/www/web1/web like index.php index.html and similar?
     
  7. edge

    edge Active Member Moderator

    Also. Is you main (WAN) IP still the same, or did your ISP change it?
     
  8. codydwilson

    codydwilson New Member

    My IP is still the same, i don't use the mail server part of ISPConfig, and i can still FTP from Cyberduck into the web files. In /var/www/ there are two directories that have my files in them, maybe that's it.

    One is /var/www/web1 and one is /var/www/grizzlypaintball.com , both look like they have all the web files in them, such as index.php, i'm running Joomla if that makes any difference.
     
  9. edge

    edge Active Member Moderator

    When I access grizzlypaintball I get: Grizzly Paintball is down for Maintenance.
    This is not the "It works page", or did you change the "it works page" to this?
     
  10. codydwilson

    codydwilson New Member

    I changed the text so it would look a little more professional, and whatnot. Before i changed it, it was "It works"
     
  11. _X_

    _X_ New Member

    i realy dont know what went wrong. anything in log files?
    /var/log/apache2/error.log?
     
    Last edited: Nov 1, 2008
  12. _X_

    _X_ New Member

  13. codydwilson

    codydwilson New Member

    Tried that, just came back with a 404 errror. The output of the apache error log is:

    Code:
    [Sun Oct 26 06:40:41 2008] [warn] long lost child came home! (pid 14186)
    [Sun Oct 26 06:40:41 2008] [warn] long lost child came home! (pid 14187)
    [Sun Oct 26 06:47:23 2008] [error] an unknown filter was not added: PHP
    ....
    
    renamed, the www.grizzlypaintball.com directory to test_grizzlypaintball like you said, that didn't seem to do anything either.
     
  14. _X_

    _X_ New Member

    that folder should be named as it was ... realized that few seconds after hitting submit reply :) sorry

    did you try restarting apache?

    /etc/init.d/apache2 restart

    and are there any error reports?

    or even restarting server?
     
  15. _X_

    _X_ New Member

    also take a look at:

    /etc/apache2/sites-available/
    Directory with files giving information on available sites.

    /etc/apache2/sites-enabled/
    Directory with links to the files in sites-available for enabled sites.

    but there is nothing realy interesting there actualy.
     
  16. _X_

    _X_ New Member

    whats in your:
    /etc/hosts
    /etc/hostname
     
  17. _X_

    _X_ New Member

    comparing your Vhosts_ispconfig.conf with mine I found one difference:
    I have this line in my <VirtualHost 111.222.333.444.:80> below Vhost part:

    ServerAlias domain.com

    http://httpd.apache.org/docs/2.0/mod/core.html#serveralias

    so it should look like this:
    ######################################
    # Vhost: www.grizzlypaintball.com:80
    ######################################
    #
    #
    <VirtualHost 69.146.169.180:80>
    ServerName www.grizzlypaintball.com:80
    ServerAdmin [email protected]
    ServerAlias grizzlypaintball.com
    DocumentRoot /var/www/web1/web
    DirectoryIndex index.php index.php5 index.php4 index.php3 index.shtml index.cgi
    index.pl index.jsp Default.htm default.htm
    ErrorLog /var/www/web1/log/error.log
     
    Last edited: Nov 1, 2008
  18. codydwilson

    codydwilson New Member

    Ok well i think we're getting somewhere, now when i restart it it says:

    Code:
    [email protected]:~# /etc/init.d/apache2 restart
     * Restarting web server apache2
    [Sat Nov 01 17:51:21 2008] [warn] NameVirtualHost 69.146.169.180:80 has no VirtualHosts
    [Sat Nov 01 17:51:31 2008] [warn] NameVirtualHost 69.146.169.180:80 has no VirtualHosts
       ...done.
    
    The file is still the but now it doesn't seem to be used. The output from hosts/hostname all look good.

    Also this is interesting:

    /etc/apache2/sites-available/ only lists default



    /etc/apache2/sites-enabled/ 000-default

    maybe didn't re enable correctly after a2dissite
     
  19. _X_

    _X_ New Member

    that's normal ... the same is on my server
     
  20. _X_

    _X_ New Member

    does both (default and 000-default) start with:
    NameVirtualHost *
    <VirtualHost *>
     

Share This Page