help setting up mail on other server

Discussion in 'ISPConfig 3 Priority Support' started by divine, Jul 23, 2014.

Thread Status:
Not open for further replies.
  1. divine

    divine New Member


    i have tried to setup an email server as separate from panel server, but with no luck.

    I have installed ispconfig3 on mail server and it went fine, the second server appears in panel.

    But when i create a domain for email it creates it on local database (though the mail server is chosen) and not on mail server. In ' Server services ' only mail server has a tick on Mailserver.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the settings of the client were you added the mail domain for, the new mail server ahs to be choosen there as default mailserver and you have to click on save afterwards. If you did not click on save or if the first server is shown there, then mail accounts will get added on the first server.
  3. divine

    divine New Member

    I cannot choose anything but mail server, because it is only server that has a TIck on Mailserver in Server Services menu. So problem is not here.

    Could you shed light how ispconfig communicates with other servers?

    I mean, if i create an email, how does ispconfig makes it appear on mail server? (shouldn't there be a replication set up during installation or something like this?)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The problem is very likely there, so please do exactly what I wrote above.Go to the client settings and there to the limit tabs. Check that the correct server is selected and then click on save. Then delete the email domain and mailbox of that client and create it again.
  5. divine

    divine New Member

    No, problem is not here, because correct server is selected. I have checked it (i am facing this problem since yesterday, so i have already tried many things, i came here as a last resort)

    If i create email as an admin user it creates it locally. edit: sorry it creates domain locally even with client accounts, but the message below always hangs there

    If i log in into client account then it tries to create it on Mail server, but it just always hangs here:

    The following changes are not yet populated to all servers:
    Create email domain: 1
    Create email user: 1
    Storing updates can take up to one minute. Please be patient.

    and never finished creating.
    Is there way to debug this?
    Last edited: Jul 23, 2014
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    As admin you have a server selector in the mail domain settings and the mail domain and later the mailboxes will be created on the server that you selected there as admin.

    If you create a mail domain as client, then the default server from client limits is used. you cant see in client limits if a wrong server is selected if the client was added bafore you added the mailserver. for that reason you have to redo the steps that I explained above.

    And what do you mean with creates locally, it is created in /var/vmail? Please do not mix up records in the master database with things created locally. The main database of a cluster always contains all records of the cluster off course, otherwise you wont see them in the interface.

    This message means that your new mailserver is not connected to the master correctly, it is not able to login to the master mysql database. This happens e.g. when you did not edit the /etc/hosts files on both servers as described in the multiserver guides. For debug instructions, see here:
  7. divine

    divine New Member

    It would throw exception during install of ispconfig when it asks for Master database credentials if it fails to connect. (i have checked from command line and it connects perfectly, i have my entries in /etc/hosts too, it is the first thing i added anyway AND if it couldn't really connect to Master mysql i wouldn't see mail server appearing in Panel server, but it does appear)

    But yes, this is replication problem. After reinstalling everything and reconfiguring, ispconfig.log (previously empty) threw such error:
    23.07.2014-12:01 - ERROR - Replication failed. Error: (client) in MySQL server: (localhost) Unknown column 'gender' in 'field list'

    problem solved. ( by downloading latest version {i don't know why it downloaded older version when i clicked download; master server was running for quite some time on, and mail server appeared yesterday but i have downloaded from Download page and got 3.5.3 and never payed attention, today i clicked on main Download button near and got }; )

    Big thanks for help, till
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not nescessarily the case. As you connect to the system with the mysql root user and not the mysql user that is created by the installer for the updates later. If /etc/hosts are wrong, then the user that gets created by the installer is wrong and the slave server is not able to connect to the master.
Thread Status:
Not open for further replies.

Share This Page