help resolving shared IP error/issue.

Discussion in 'Installation/Configuration' started by pootle, Feb 21, 2007.

  1. pootle

    pootle New Member


    I'm extremely new to ISPConfig (please be gentle) and I've built it in a virtual machine for testing..

    I've built it on suse 10.2 and when I add a new virtual site, the ip address if that of the local device (taken from ifconfig).

    I have a monowall firewall with the DNS resolution theres an A NAME record there to resolve the site. When I'm on the vm box i can type ping and it will return the ip address (matches that from ifconfig).

    When I slap this into a browser and type i get the shared IP error :(. This is the same if I do it with the ip which I would expect.

    Anyway I'm not sure whats what at this stage as I think everythings right might be something stupid that i've missed and I could do with someones input.

    For the record I'm using the last release not the one that was relased today :)
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You get the shared IP page because you selected the wrong IP address for the website. If you are in a NAT enviroment, you must use the internal IP and not the external.
  3. pootle

    pootle New Member

    when I run ifconfig I get and thats the IP address thats being used by ISPConfig and on the monowall box this is the DNS record...

    Yes the VM is running in NAT mode but I thought this was correct, when I run ifconfig no other IP is returned...sorry if I seem a little thick here, is there another address that I'm missing?!
  4. pootle

    pootle New Member

    found the problem i think theres an extra . appearing in the domain i must have done and not so its :(. numpty award number two. If its not that i'll post back
  5. pootle

    pootle New Member

    yep that got it..i'd done all over the place for some bizzare reason its working now.

    Sorry im two for two today think i'll just but the laptop down and go to bed :D

Share This Page