help postfix covecot opensuse 11.1

Discussion in 'Server Operation' started by mkeigwin, Oct 15, 2009.

  1. mkeigwin

    mkeigwin New Member

    i have open suse postfix dovecot mail server set up
    when i connect to the mail server from a vista pc , windows mail , i can only send email outgoing if i have the local server ip in the outgoing smtp address . if i try to use the mail server wan domain name i get a relay denied and can not send out email .

    i will be moving this server to my work and i still need to be able to connect and send email from home .

    where do i start to fix this , thanks
  2. falko

    falko Super Moderator ISPConfig Developer

    Does the hostname point to your router's public IP, and is your router configured to forward port 25 to your mailserver?

    It's also possible that your router doesn't suppport loopbacks. Or your provider is blocking port 25.
  3. mkeigwin

    mkeigwin New Member

    i have a static ip and rev dns points back to my domain name . mx is set for backup set for godaddy mail server .

    this is a copy of my postfix

    readme_directory = /usr/share/doc/packages/postfix-doc/README_FILES
    inet_protocols = all
    biff = no
    mail_spool_directory = /var/mail
    canonical_maps = hash:/etc/postfix/canonical
    virtual_alias_maps = hash:/etc/postfix/virtual
    virtual_alias_domains = hash:/etc/postfix/virtual
    relocated_maps = hash:/etc/postfix/relocated
    transport_maps = hash:/etc/postfix/transport
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    masquerade_classes = envelope_sender, header_sender, header_recipient
    myhostname =
    myorigin =
    delay_warning_time = 1h
    message_strip_characters = \0
    program_directory = /usr/lib/postfix
    defer_transports =
    disable_dns_lookups = no
    mailbox_command =
    mailbox_transport =
    strict_8bitmime = no
    disable_mime_output_conversion = no
    smtpd_sender_restrictions = hash:/etc/postfix/access
    smtpd_client_restrictions =
    strict_rfc821_envelopes = no
    smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
    smtp_sasl_auth_enable = no
    smtpd_use_tls = no
    alias_maps = hash:/etc/aliases
    mailbox_size_limit = 0
    message_size_limit = 10240000
    append_dot_mydomain = no
    swap_bangpath = no
    masquerade_domains =
    masquerade_execeptions = root
    smtpd_sasl_auth_enable = no
    smtpd_use_tls = no
    home_mailbox = Maildir/
    relay_domains = mynetworks

    this is a copy of my dovecot config file

    ## Dovecot configuration file

    protocols = imap pop3 imaps pop3s

    listen =

    disable_plaintext_auth = no

    ssl_listen =

    ssl_disable = yes

    mail_location = maildir:~/Maildir/

    protocol imap {

    mail_plugin_dir = /usr/lib64/dovecot/modules/imap

    imap_client_workarounds = delay-newmail outlook-idle netscape-eoh

    protocol pop3 {

    pop3_uidl_format = %08Xu%08Xv
    pop3_uidl_format = %v.%u

    mail_plugin_dir = /usr/lib64/dovecot/modules/pop3

    pop3_client_workarounds = outlook-no-nuls oe-ns-eoh

    protocol managesieve {

    protocol lda {

    postmaster_address = [email protected]

    mail_plugin_dir = /usr/lib64/dovecot/modules/lda


    auth default {

    mechanisms = plain

    passdb passwd {

    userdb passwd {

    user = root
    dict {
    plugin {
    login_process_size = 64
    Last edited: Oct 15, 2009
  4. falko

    falko Super Moderator ISPConfig Developer

    Does point to your router's public IP?
    Have you asked your ISP if they block port 25?
  5. mkeigwin

    mkeigwin New Member

    isp is not blocking port 25 and they set up the revers dns to point to my domain name . mx are correct and point back to my server . i added my public ip to the postfix main config , i setup windows mail to use the public ip as the mail server on both incoming and outgoing , seems to work from the same network , today i moves a windows 7 box to the office and it still does not want to send outgoing mail . but i can get incoming mail, still outgoing give the relay denied error , do i need to setup tls for this to work , as i do not want to use a web client , i would perfer to use imap.

    server2:~ # dig mx

    ; <<>> DiG 9.5.0-P2 <<>> mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38883
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 1

    ; IN MX

    ;; ANSWER SECTION: 1800 IN MX 0 1800 IN MX 10


    ;; Query time: 58 msec
    ;; SERVER:
    ;; WHEN: Sat Oct 17 00:18:49 2009
    ;; MSG SIZE rcvd: 111

    server2:~ # nslookup

    Non-authoritative answer: name =

    Authoritative answers can be found from:

    server2:~ # host domain name pointer
  6. falko

    falko Super Moderator ISPConfig Developer

    Can you post the exact error message?
  7. mkeigwin

    mkeigwin New Member

    The message could not be sent. The authentication setting might not be correct for your outgoing e-mail [SMTP] server. For help solving this problem, go to Help, search for "Troubleshoot Windows Live Mail", and read the "I'm having problems sending e-mail" section. If you need help determining the proper server settings, please contact your e-mail service provider.

    The rejected e-mail address was '[email protected]'.

    Subject 'test'
    Server Error: 554
    Server Response: 554 5.7.1 <[email protected]>: Relay access denied
    Server: ''
    Windows Live Mail Error ID: 0x800CCC79
    Protocol: SMTP
    Port: 25
    Secure(SSL): No
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you enable "Server requires authentication" in your email client?
  9. mkeigwin

    mkeigwin New Member

    no it is not turned on i have it set for clear for right now .
  10. falko

    falko Super Moderator ISPConfig Developer

    What do you mean with that?
  11. mkeigwin

    mkeigwin New Member

    i added the ip of the network that i am trying to use for the office and i can now send and recieve email,, i guess if i were to permit any networks i wold be a open relay . so i have set up localhost my wan ip and the office ip to be able to connect to the server . any others will not be able to send going going email.

Share This Page