Help Needed Please!!!

Discussion in 'Installation/Configuration' started by DanMB, Mar 13, 2006.

  1. DanMB

    DanMB New Member

    Hello,
    I am really interted installing ISPConfig but im having no luck
    Im using CentOS 4.2 and ive also installed the latest zlib
    Im getting an error during installation:

    NOTE: the optional IO::Zlib module is not installed.

    The "sa-update" script requires this module to access compressed
    update archive files.

    REQUIRED module missing: Digest::SHA1
    REQUIRED module missing: HTML::parser
    optional module missing: Net:NS
    optional module missing: Mail::SPF::Query
    optional module missing: IP::Country
    optional module missing: Razor2
    optional module missing: Net::Ident
    optional module missing: IO::Socket::INET6
    optional module missing: IO::Socket::SSL
    optional module missing: Time::HiRes
    optional module missing: LWP::UserAgent
    optional module missing: HTTP:ate
    optional module missing: Archive::Tar
    optional module missing: IO::Zlib

    warning: some functionality may not be available,
    please read the above report before continuing!

    ERROR: Could not configure SpamAssassin
    cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
    mv: cannot stat `binaries/aps.tar.gz': No such file or directory
    mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
    mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
    mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
    mv: cannot stat `binaries/cronolog': No such file or directory
    mv: cannot stat `binaries/cronosplit': No such file or directory
    mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
    mv: cannot stat `binaries/zip': No such file or directory
    mv: cannot stat `binaries/unzip': No such file or directory
    tar: spamassassin.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `spamassassin': No such file or directory
    tar: uudeview.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `uudeview': No such file or directory
    tar: clamav.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    mv: cannot stat `clamav': No such file or directory
    tar: aps.tar.gz: Cannot open: No such file or directory
    tar: Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    ./setup2: line 777: ispconfig_tmp/php/bin/php: No such file or directory
    ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!

    PLEASE Help

    Thank You
     
    Last edited: Mar 13, 2006
  2. DanMB

    DanMB New Member

    Ive looked through the error log and looked for zlib modules couldnt find any - Im very new to the whole thnk and very stuck- can some one please help

    **Ps sorry for double post
     
  3. falko

    falko Super Moderator

    You must install these two Perl modules, as described here: http://www.howtoforge.com/perfect_setup_fedora_core_4_p5 (Fedora Core 4 is very similar to CentOS, so this should work for you).
     
  4. DanMB

    DanMB New Member

    YEY i now have it installed but:

    Starting ISPConfig system...
    Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
    Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: /root/ispconfig/httpd/libexec/libphp5.so: undefined symbol: compress
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    FreshClam is already running!
    ISPConfig system is now up and running!
     
  5. till

    till Super Moderator

    Did you get any errors during ISPConfig installation? Please check the install log in /var/log/ispconfig_install.log
     
  6. DanMB

    DanMB New Member

    Heres the log:

    Code:
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - created mydestination entry in /et$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
    Mon Mar 13 23:19:27 GMT 2006 - [ISPConfig] - httpd restart successful
    Mon Mar 13 23:19:29 GMT 2006 - [ISPConfig] - postfix restart successful
    Mon Mar 13 23:19:37 GMT 2006 - [ISPConfig] - file /root/ispconfig/dist.info del$
    Mon Mar 13 23:19:43 GMT 2006 - [ISPConfig] - directory install_ispconfig deleted
    Mon Mar 13 23:19:43 GMT 2006 - [ISPConfig] - ##############################
    
     
  7. DanMB

    DanMB New Member

    Sorry for double post but whats his mean:
    Code:
    Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
    Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: /root/ispconfig/httpd/libexec/libphp5.so: undefined symbol: compress
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    and how do i fix it
     
  8. falko

    falko Super Moderator

    Something's wrong with ISPConfig's PHP...
    When you installed ISPConfig, did you use the original ISPConfig sources, or did you maybe modify install_ispconfig/compile_aps/compile before?

    What's the output of
    Code:
    uname -m
    ?
     
  9. DanMB

    DanMB New Member

    i686 is the output
    Also i didnt modify anyhting

    Anyone know how to resolve this error?
     
    Last edited: Mar 16, 2006
  10. falko

    falko Super Moderator

    Did you encounter anything unusual during the ISPConfig installation? Errors, warnings, ...?
     
  11. DanMB

    DanMB New Member

    Nope all went smoothly
     
  12. DanMB

    DanMB New Member

    Sorry to double post but can anyone PLEASE help i need to get this up

    Thank you
     
  13. falko

    falko Super Moderator

    Please try to install ISPConfig over the existing ISPConfig (the installer will then perform an update). Maybe this fixes the PHP problem...
     
  14. DanMB

    DanMB New Member

    Fixed it now, i installed usingg DSA now it works ;S
     
  15. DanMB

    DanMB New Member

    Error after error :( i can login etc and see the menus on the left, some of the work on the left and others dont some that dont work are in management and the ones under 'Form designer' and 'Management' dont work they come up 'page cannot be displayed' Can you help?
     
    Last edited: Mar 18, 2006
  16. falko

    falko Super Moderator

    That means you entered a wrong hostname and domain during the installation.

    Please set the correct URL in /home/admispconfig/ispconfig/lib/config.inc.php and the correct ServerName in /root/ispconfig/httpd/conf/httpd.conf and restart ISPConfig:
    Code:
    /etc/init.d/ispconfig_server restart
     

Share This Page