Help, my phpfiles arenot parsing.

Discussion in 'Installation/Configuration' started by pgp_protector, Aug 6, 2007.

  1. pgp_protector

    pgp_protector New Member

    Ok total noob to both Linux & ISPConfig.

    I've got a SuSE 10.2 Box with 1G / 320G HD clean install from the step by step instructions.

    Got it up and running, and can use the Admin panels (So PHP on the box is working)

    I created a new Site www.testsite.home for inhouse testing as I learn this.

    When I created the site I could visit it from my XP Box (updated the host file so it would go to the IP address), and it displays the index.html file with no problem.

    But when I changed the index.html file to old_index.html, so it would serve index.php instead. well it will not parse the file (run the php script) but the computer that connects to the server is asked to download the file instead.

    Where do I start to look for this ?

    The index.php file is just the <?php phpinfo(); ?> command.

    I've turned on PHP Scripts: under site management and tried both PHP Safe Mode: enabled and disabled.
     
  2. till

    till Super Moderator

    Please edit the config file /home/admispconfig/ispconfig/lib/config.inc.php and change the line:

    Code:
    $go_info["server"]["apache2_php"] = 'both'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)
    
    to:

    Code:
    $go_info["server"]["apache2_php"] = 'addhandler'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)
    
    and then edit a setting in your site, e.g. quota, in ISPConfig and click on save to let ISPConfig rewrite the apache config file.
     
  3. pgp_protector

    pgp_protector New Member

    Thank you that fixed it, it's now working :) :clap:
     
  4. ivantea

    ivantea New Member

    hello till I have the same problems with pgp protector, my php index.php files canot parsing, i using fedore core 7 there is the same configuration as suse please help me
     
  5. till

    till Super Moderator

    Fedora 7 uses another configuration the SuSE, so this Thread does not apply to you as PHP on Fedora 7 will not work when you use Addhandler.

    Please make sure that you configured your server exactly as decsribed in the perfect setup guide for fedora 7, php will work then with ISPConfig out of the box, no changes needed.
     

Share This Page