Help!!! Must be a php problem

Discussion in 'Installation/Configuration' started by jeeperss98, Mar 31, 2006.

  1. jeeperss98

    jeeperss98 New Member

    Hello to all, I am installing and configuring ISPConfig for the first time in a production environment and most things work great. Love the program-far superior over IIS 6.0 for Windows server 2003.

    But my problem is that .php scripts are not working. I am running the default installation on a Suse 10 environment. I have done both text only installs and Graphical and currenting using a Graphical interface (Gnome) Everything installs perfect per the how to guide (ISPConfig Perfect Setup SuSE 10). My websites are all working great except for anything looking for a php script. So for example one of my sites has a .php google search scritp and when activated the page is just blank. No error, nothing parsed to the browser, nothing, nada, zip, zero, zilch.

    Another site I have has a php catalog installer (OsCommerce 2.20) and when first browsing to the install page http://defaultsite/catalog/install/install.php I got a FATAL_ERROR: register_globals is turned off. Ok fine I edited php.ini to register_globals = On and now I get that same darned blank screen. So what is going on here?????

    HELPPPPPP?????? I need these sites up like yesterday.

    HowToForge Newb
  2. edge

    edge Active Member Moderator

    php_admin_flag register_globals on
    php_admin_flag register_long_arrays on
    to the site's Apache Directives

    You will find the Apache Directives in the ISP Site > basis (at the bottom)
  3. jeeperss98

    jeeperss98 New Member

    Ok I had already fixed that but

    But now i get an error:

    Warning: main(includes/functions/general.php) [function.main]: failed to open stream: No such file or directory in /var/www/web4/web/catalog/install/includes/application.php on line 22

    Fatal error: main() [function.require]: Failed opening required'includes/functions/general.php' (include_path='/usr/share/php5') in /var/www/web4/web/catalog/install/includes/application.php on line 22

    Ok so I have verified that both of those files are there the only thing I am concerned about in this error is the "(include_path='/usr/share/php5') I have no Idea why it is requesting that path(somebody help there)

    So I hope that gives a little more light on to the problem. I did enable the errors so I was able to put out these errors.

    Thanks for your help!

  4. edge

    edge Active Member Moderator

  5. falko

    falko Super Moderator ISPConfig Developer

    Open your php.ini and set the include_path to

    include_path = ".:/usr/share/php5"
    Then restart Apache.
  6. jeeperss98

    jeeperss98 New Member

    Thank You Thank you

    That was the trick. I appreciate your help so much thanks :D

Share This Page