Help me to install RoundCube

Discussion in 'General' started by MacSIM, Apr 15, 2008.

  1. MacSIM

    MacSIM New Member

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Enter the email address and password of a mail user that you created in ISPConfig. If this wont work, please try the username instaed of the email address, I'am not sure if the roundcube instaler is able to lookup the username for the email address automatically.
     
  3. MacSIM

    MacSIM New Member

    hello and thx you for your answer.

    I have always this error :

    Connecting to IP...
    IMAP connect: NOT OK(Authentication for [email protected] failed (LOGIN): "a001 NO Login failed.")

    I have done a couple of test :
    username : web2_maxime ; [email protected] ; [email protected] ; maxime ; [email protected] ; [email protected]
    server : 127.0.0.1 ; public IP

    But, always this error :mad:

    Thx you for your help.
     
  4. Hans

    Hans Moderator ISPConfig Developer

    Can you login into RoundCube and sent/receive mail?
    If so, you can remove the installer, because the right configuration files are delivered with the package already.
     
  5. MacSIM

    MacSIM New Member

    No I can't login with all my email account :(
     
    Last edited: Apr 16, 2008
  6. falko

    falko Super Moderator ISPConfig Developer

    You must send an email first to a new account before you can login. The necessary folders are created automatically when the first email arrives.
     
  7. MacSIM

    MacSIM New Member

    If I send a mail to :
    [email protected]
    => I have a Mail Delivery failure:
    Technical details of permanent failure:
    PERM_FAILURE: DNS Error: DNS server returned answer with no data

    If I send a mail to:
    [email protected]
    => I don't have Mail Delivery failure, so I think it's ok !

    But, I still can't get connected to roundcube :(

    What do I put in RoundCube exactly (username and server) ?

    I think (I'am not sure..) that it's not a problem with server IMAP because if I put for example 77.77.77.77 for the server IP imap, I have a "imap connection error", but with localhost or my public IP it's ok beaucause I haven't error.

    I always have this error : "Login failed" :mad: (for my two account).

    Thx you, all, for your help :)
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please fix the dns error first. Make sure that the domain domain.tld points to the IP of your server in DNS.

    If you used the ISPConfig Roundcube package, you login with the email address and password, not the username.
     
  9. MacSIM

    MacSIM New Member

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please have a look in the mail log and post the exact error messages.
     
  11. MacSIM

    MacSIM New Member

    I have this :

    Apr 17 15:07:49 serveur imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 17 15:07:49 serveur imapd: LOGIN FAILED, user=maxime@mydomain.tld, ip=[::ffff:127.0.0.1]
    Apr 17 15:07:54 serveur imapd: Disconnected, ip=[::ffff:127.0.0.1], time=5
     
  12. MacSIM

    MacSIM New Member

    I have actived DEBUG_LOGIN=2 in /etc/courier/authdaemonrc

    And now I have this in .log :

    Apr 17 17:45:34 serveur imapd: Connection, ip=[::ffff:127.0.0.1]
    Apr 17 17:45:34 serveur imapd: LOGIN FAILED, user=maxime@mydain.tld, ip=[::ffff:127.0.0.1]
    Apr 17 17:45:34 serveur authdaemond: received auth request, service=imap, authtype=login
    Apr 17 17:45:34 serveur authdaemond: authpam: trying this module
    Apr 17 17:45:34 serveur authdaemond: authpam: username '[email protected]' not found in password file
    Apr 17 17:45:34 serveur authdaemond: authpam: REJECT - try next module
    Apr 17 17:45:34 serveur authdaemond: FAIL, all modules rejected
    Apr 17 17:45:39 serveur imapd: Disconnected, ip=[::ffff:127.0.0.1], time=5


    Thx for your help;)
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Your roundcube seems not to be configured to lookuo the username from the email address. In this case you will have to use the username to login.
     
  14. apage

    apage New Member

    Help Please

    I have just setup my website a new Debian based dedicated server.

    My Hosting company have setup Round cube and will not help with anymore software related issues!!

    It is not working. I think it needs to be reinstalled and setup properly. Also I can only login to it via outlook to recieve emails but it seems emails never arrive. I can not use outlook to send emails to any of the email accounts that have been created. Also my website relies on being able to send emails via smtp so that the emails go through the correct authentication and get delivered.

    Please help! I don't know where to start as I am a newbie to linux. I am willing to pay to have somoeone set this up for me. I can pay via paypal :)

    Please...
     
  15. apage

    apage New Member

    Help Please

    I also have other things like Postfixadmin installed???
     
  16. apage

    apage New Member

    Help Please

    And Dovecot. I am not sure that any of them are working corectly though.
     
  17. Hans

    Hans Moderator ISPConfig Developer

    What is within your mail log /var/log/mail.log ?
    Do you see any related errors?
     
  18. apage

    apage New Member

    erm

    there are over 8000 entries in the file and the server has only been up for 4 days :-(

    There is lots in there anything I should be looking for in particular?
     
  19. apage

    apage New Member

    Erm

    There are lots of things like this...

    May 26 11:35:56 itholdings postfix/pickup[17597]: 4E379ECB983: uid=33 from=<[email protected]>
    May 26 11:35:56 itholdings postfix/cleanup[17704]: 4E379ECB983: message-id=<[email protected]>
    May 26 11:35:56 itholdings postfix/qmgr[13614]: 4E379ECB983: from=<[email protected]>, size=3905, nrcpt=1 (queue active)
    May 26 11:35:57 itholdings postfix/smtp[17707]: 4E379ECB983: to=<[email protected]>, relay=mx1.hotmail.com[65.54.244.8]:25, delay=1.4, delays=0.07/0.01/0.48/0.81, dsn=2.0.0, status=sent (250 <[email protected]> Queued mail for delivery)
    May 26 11:35:57 itholdings postfix/qmgr[13614]: 4E379ECB983: removed
     
  20. apage

    apage New Member

    More

    I just found this in there,

    May 25 10:21:44 itholdings postfix/smtpd[10510]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
    May 25 10:21:44 itholdings postfix/smtpd[10510]: connect from 121-73-39-227.cable.telstraclear.net[121.73.39.227]
    May 25 10:21:44 itholdings postfix/smtpd[10510]: NOQUEUE: reject: RCPT from 121-73-39-227.cable.telstraclear.net[121.73.39.227]: 504 5.5.2 <mohawkboi69>: Helo command rejected: need fully-qualified hostname; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mohawkboi69>
    May 25 10:21:47 itholdings postfix/smtpd[10510]: disconnect from 121-73-39-227.cable.telstraclear.net[121.73.39.227]
     

Share This Page