help link is not working, pop3 is offline

Discussion in 'Installation/Configuration' started by xianusa, Mar 28, 2006.

  1. xianusa

    xianusa New Member

    Hi Folks,

    I have installed ISPconfig 2.2 on centos 4.2. I got it working but I have 2 issues:
    1) when I am trying to create a reseller and I enter the company name and try to click on the image at the right side of the company's name {https://localhost:81/design/default/icons/help14.gif} link to the following address returns:

    The connection was refused when attempting to conect test.org:81

    2) service show pop3 is of line, I checked some threads and did not find any answer

    your help is very appricated
    Regards
    xian
     
  2. falko

    falko Super Moderator

    What's the URL you have in /home/admispconfig/ispconfig/lib/config.inc.php? What's the ServerName you have in /root/ispconfig/httpd/conf/httpd.conf?

    Do you have a POP3 daemon installed? If so, which one? What's the output of
    Code:
    netstat -tap
    ? If it doesn't show up there, try to start your POP3 daemon on the command line.
     
  3. xianusa

    xianusa New Member

    Hi Falko, I really appreciate you responce to the new comers and my posting.
    from centos 4.2 I installeded everything except aquirmail and mail man and yet I am unable to fined pop3 deamon
    netstat -tap shows:
    ###########################
    [root@www ~]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address Stat e PID/Program name
    tcp 0 0 *:807 *:* LIST EN 2321/rpc.statd
    tcp 0 0 *:mysql *:* LIST EN 2639/mysqld
    tcp 0 0 www.test.org:783 *:* LIST EN 22792/spamd.pid
    tcp 0 0 *:sunrpc *:* LIST EN 2301/portmap
    tcp 0 0 *:81 *:* LIST EN 3044/ispconfig_http
    tcp 0 0 www.test.org:domain *:* LIST EN 3239/named
    tcp 0 0 www.test.org:domain *:* LIST EN 3239/named
    tcp 0 0 *:ftp *:* LIST EN 2547/vsftpd
    tcp 0 0 www.test.org:ipp *:* LIST EN 22662/cupsd
    tcp 0 0 www.test.org:smtp *:* LIST EN 22723/sendmail: acc
    tcp 0 0 www.test.org:rndc *:* LIST EN 3239/named
    tcp 0 0 *:imaps *:* LIST EN 2453/dovecot
    tcp 0 0 *:imap *:* LIST EN 2453/dovecot
    tcp 0 0 *:http *:* LIST EN 3147/httpd
    tcp 0 0 *:ssh *:* LIST EN 22542/sshd
    tcp 0 0 *:https *:* LIST EN 3147/httpd
    #######################
    What should I do?:confused:
    Thanks
     
  4. falko

    falko Super Moderator

    You have dovecot installed which provides POP3 services. Please restart dovecot:
    Code:
    /etc/init.d/dovecot restart
    and check again with
    Code:
    netstat -tap
    if POP3 is up then.
     
  5. xianusa

    xianusa New Member

    Hi Falko,
    thanks for your help, I just did what you said and still I dont see pop:
    ++++++++++++++++++++++++++++++
    [root@www phpmyadmin]# /etc/init.d/dovecot restart
    Stopping Dovecot Imap: [ OK ]
    Starting Dovecot Imap: [ OK ]
    [root@www phpmyadmin]# netstat -tap
    Active Internet connections (servers and established)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:mysql *:* LISTEN 2499/mysqld
    tcp 0 0 www.test.org:783 *:* LISTEN 2552/spamd.pid
    tcp 0 0 *:sunrpc *:* LISTEN 2158/portmap
    tcp 0 0 *:81 *:* LISTEN 2933/ispconfig_http
    tcp 0 0 www.test.org:domain *:* LISTEN 3052/named
    tcp 0 0 www.test.org:domain *:* LISTEN 3052/named
    tcp 0 0 *:ftp *:* LISTEN 2404/vsftpd
    tcp 0 0 www.test.org:ipp *:* LISTEN 2327/cupsd
    tcp 0 0 *:664 *:* LISTEN 2178/rpc.statd
    tcp 0 0 www.test.org:rndc *:* LISTEN 3052/named
    tcp 0 0 www.test.org:smtp *:* LISTEN 2532/sendmail: acce
    tcp 0 0 www.test.org:33193 a69-225-175-104.deploy:http ESTABLISHED 4184/firefox-bin
    tcp 0 0 www.test.org:33203 209.62.186.11:http ESTABLISHED 4184/firefox-bin
    tcp 0 0 www.test.org:33197 64.233.167.99:http ESTABLISHED 4184/firefox-bin
    tcp 0 0 www.test.org:33194 a69-225-175-105.deploy:http ESTABLISHED 4184/firefox-bin
    tcp 0 0 *:imaps *:* LISTEN 7268/dovecot
    tcp 0 0 *:imap *:* LISTEN 7268/dovecot
    tcp 0 0 *:http *:* LISTEN 2958/httpd
    tcp 0 0 *:ssh *:* LISTEN 2379/sshd
    tcp 0 0 *:https *:* LISTEN 2958/httpd
    [root@www phpmyadmin]#
    ++++++++++++++++++++++++++++++
    thanks
     
  6. till

    till Super Moderator

    Maybe dovecot on centos 4.2 has separate imap and pop3 packages :confused: Please check if there is an dovecot pop3 package available.
     
  7. falko

    falko Super Moderator

    And please post the output of
    Code:
    updatedb
    locate dovecot
    I guess there must be some kind of configuration file.
     
  8. xianusa

    xianusa New Member

    Hi Falko,
    I fix the problem:
    to resolve this pop3 issue in centos 4.2, you must edit dovecot.conf file in /etc directory
    and add pop3 pop3s to porotocols
    # Protocols we want to be serving:
    # imap imaps pop3 pop3s
    protocols = imap imaps pop3 pop3s

    Thanks for puting up with rockies
     

Share This Page