Help installing courier

Discussion in 'Installation/Configuration' started by n0rbertt, Feb 16, 2011.

  1. n0rbertt

    n0rbertt New Member

    So I'm trying to install courier and I first got the error :

    configure: error: Courier authentication library version 0.63 is required.

    So I installed it , but I still get the error.

    So I see on this post it is suggested to install courier-imap but that still gives me this error :


    checking for courierauthconfig... /usr/bin/courierauthconfig
    configure: error: Courier authentication library version 0.61 required.
     
  2. n0rbertt

    n0rbertt New Member

    Anyone Please ?
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Which distribution and which tutorial (URL) do you use?
     
  4. n0rbertt

    n0rbertt New Member

  5. falko

    falko Super Moderator ISPConfig Developer

  6. n0rbertt

    n0rbertt New Member

    The newest version.
     
  7. falko

    falko Super Moderator ISPConfig Developer

    When exactly do you get the error? When you build courier-authlib, courier-imap, or maildrop?
     
  8. n0rbertt

    n0rbertt New Member

    The main courier program
     
  9. n0rbertt

    n0rbertt New Member

    So I ussue this command : sudo rpm -ivh courier-authlib-0.63.0-1.x86_64.rpm

    and get :

     
  10. falko

    falko Super Moderator ISPConfig Developer

    You installed courier-authlib-0.60.2-1.x86_64 before courier-authlib-0.63.0-1.x86_64, right? Please uinstall courier-authlib-0.60.2-1.x86_64, and then try to install courier-authlib-0.63.0-1.x86_64 again.
     
  11. n0rbertt

    n0rbertt New Member

    How do you go about the uninstall process? Don't even know ...
     
  12. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    rpm -e courier-authlib
    or
    Code:
    yum remove courier-authlib
     

Share This Page