HELP: Default Web location is /var and not /var/www

Discussion in 'General' started by astewart, Feb 4, 2010.

  1. astewart

    astewart ISPConfig Developer

    Ubuntu 8.04
    Latest version of ispconfig

    Why does ispconfig 3 think that /var is the main Document root.

    With any new installs of ispconfig the default location is /var/www

    Where or what file to I have to modifiy to allow ispconfig 3 to start creating sites under /var/www and not /var ?

    I had moved the original client folder from /var to /var/www and re-created all the proper symlinks, which everything is working as far as browsing the sites go.

    But any change from within the ispconfig 3 control panel, it created a whole new 'clients' folder in /var and doesn't modifiy the one that was moved. So any modifications through the CP only affect the Client sites under /var ant not the clients in /var/www.
    :(

    So I just need to know 'what' is telling ispconfig that the default Web Root location is /var ?

    Thanks!
     
  2. till

    till Super Moderator

    Take a look in the ispconfig server settings and make sure that the correct path for symlinks and websites is set. It has to be:

    website basedir: /var/www
    website path: /var/www/clients/client[client_id]/web[website_id]
    website symlinks: /var/www/[website_domain]/:/var/www/clients/client[client_id]/[website_domain]/
     
  3. astewart

    astewart ISPConfig Developer

    OMG I was looking to deep into this. I was looking around for a specific config file that might contain that info and all this time it was in the CP...:eek:

    Sorry for the stupid question man...

    Ya, the website path was set to: /var/clients/client[client_id]/web[website_id]
    Which I had modified.


    Anyways I was able to migrate the existing 'client' folder from /var to /var/www and manually modified all symlinks and hardcoded paths in a few other files.

    Ran into a couple issues but I was able to work them out and everything appears to be working as it should.

    So I am now able to run suexec properly now too :)

    Thanks again!
     

Share This Page