Help - Apache not starting ? After SSL install ???

Discussion in 'General' started by whiz_kid_uk, Oct 28, 2011.

  1. whiz_kid_uk

    whiz_kid_uk New Member

    Hi Guys,
    I have an issue, (And its not very often I know) but I installed a ssl cert on a website in ispconfig, and now apache will not start

    If I run apache2 or sudo apache2
    I get apache2: bad user name $[apache_run_user}


    Help I have seached and searched !!!

    TIA
     
  2. till

    till Super Moderator

    Go to the apache sites-enabled folder and delete the symlink for the website where you enabled the ssl certificate and then restart apache. Then login to ispconfig and uncheck the ssl checkbox for that site and click on save.

    To find the resaon for the problem, please describe how exactly did you install the ssl cert? As apache does not start if the ssl cert is damaged or if you created the ssl cert outside of ispconfig so that the ssl key of the cert is incorrect.
     
  3. whiz_kid_uk

    whiz_kid_uk New Member

    Hi Till - Thanks for the help - How do I del a sym link - sorry still learning with the help of the forums !
    -Me being silly !

    I have deleted the site from /etc/apache2/sites-enabled

    Apache error still there !
     
    Last edited: Oct 28, 2011
  4. whiz_kid_uk

    whiz_kid_uk New Member

    This is what I did,
    I got the CSR from the server got geotrust ssl generated and pasted the cert in the cert box and selected save.
    Thats when it all went pair shapped.

    I removed the sym link and rebooted and the sites are all working apart from the site that I enabled the ssl on all I get now is the this is the default page for this web server !
     
  5. whiz_kid_uk

    whiz_kid_uk New Member

    OK normal site is back on, however enabling ssl does not work ???
     
  6. whiz_kid_uk

    whiz_kid_uk New Member

    Every time I enable ssl for this site - it brings the server down ??
     
  7. whiz_kid_uk

    whiz_kid_uk New Member

    The version of ispconfig is : 3.0.2.2
    Running on unbuntu
     
  8. falko

    falko Super Moderator

    What error message do you get when you restart Apache?

    Any errors in Apache's error log? Is mod_ssl enabled?
     
  9. whiz_kid_uk

    whiz_kid_uk New Member

    Hi Falco,

    I did try and look at the log, and could not see anything, not sure how to check if mod ssl bit ??

    J
     
  10. falko

    falko Super Moderator

    Try
    Code:
    a2enmod ssl
    /etc/init.d/apache2 restart
     
  11. whiz_kid_uk

    whiz_kid_uk New Member

    Hi Falko
    Module ssl already enabled
    Restart ok.

    Now website does not crash the system, but https: is no longer available for that site ??
     

Share This Page