Help After Upgrade Ubuntu

Discussion in 'Installation/Configuration' started by tellar, Aug 18, 2007.

  1. tellar

    tellar New Member

    I have just upgraded ubuntu to the newest version and stupidly enough I have let the upgrade overwrite the links in the virtual hosts and apache config files to ispconfig.

    is there a way to redirect apache back to the ispconfig system? all files for ispconfig are still fine and working (great that ispconfig runs in its own server) the websites are still on the server but all links between the 2 systems are lost.

    I can find the virtual hosts file back in the apache2 folders but the new instalation is using the new apache files
     
    Last edited: Aug 18, 2007
  2. tellar

    tellar New Member

    update to problem

    I think that I need to tell the apache server that the virtual hosts file should look into ispconfigs virtual host file but I am not sure how to do it
     
    Last edited: Aug 18, 2007
  3. tellar

    tellar New Member

    how to update apache file to include ispconfig vhosts

    I can not log into mysql via phpmy admin also so I think that the link is lost there too The Databases are there however
     
    Last edited: Aug 18, 2007
  4. falko

    falko Super Moderator ISPConfig Developer

    Please add this at the end of /etc/apache2/apache2.conf:

    Code:
    ###############ispconfig_log###############
    LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
    CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig
    
    <Directory /var/www/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/user/*/web>
        Options +Includes -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    <Directory /var/www/*/cgi-bin>
        Options ExecCGI -Indexes
        AllowOverride None
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
        <Files ~ "^\.ht">
        Deny from all
        </Files>
    </Directory>
    
    Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
    (You might have to adjust the paths in this code snippet.)
     

Share This Page