Helo command rejected: need fully-qualified hostname

Discussion in 'Server Operation' started by abrichr, Aug 14, 2012.

  1. abrichr

    abrichr New Member

    Hello,

    This is my first time attempting to configure a mail server. For the purposes of this thread, let my domain name be abc.com.

    I followed the instructions at http://www.exratione.com/2012/05/a-mailserver-on-ubuntu-1204-postfix-dovecot-mysql/.

    Outgoing mail seems to be working; the problem is with incoming mail. The message on the server says:

    postfix/smtpd[2642]: NOQUEUE: reject_warning: RCPT from abc: 504 5.5.2 <phil>: Helo command rejected: need fully-qualified hostname; from=<andrew@abc.com> to=<andrew@abc.com> proto=SMTP helo=<phil>

    In this case, abc.com is an existing domain name that does not currently point to this server. I wish to configure this server fully before changing the DNS so as to minimize downtime.

    Furthermore, "phil" is the name of the local computer I am using to connect to the mail server. It seems unreasonable to me for the server to expect that every client machine has a fully qualified domain name. Therefore, I suspect that something is wrong with the configuration settings specified in the tutorial I followed.

    Any help in this matter would be greatly appreciated.

    Version information:

    /etc/postfix/main.cf:


     
    Last edited: Aug 14, 2012
  2. falko

    falko Super Moderator Howtoforge Staff Moderator HowtoForge Supporter ISPConfig Developer

    Do you have a fully-qualified hostname in /etc/hostname, or is it just phil?
     
  3. abrichr

    abrichr New Member

Share This Page