Hello ISPConfig3 PRoblem!

Discussion in 'Installation/Configuration' started by sysroot, Aug 28, 2013.

  1. sysroot

    sysroot New Member

    Hi there. I'm new here but I had a question and in need of alot of help. I've installed ISPConfig3, and pre-req's using The PERFECT server with Apache2, and now whenever I goto www.seekanet.com (my domain); it goes directly to my mail? Any ideas on how to fix this? Please no bits and pieces. I am already dumb enough haha!

    Also: I may edit now that seekanet.com does not even resolve!, and ISPConfig will not let me 'add a site' - everytime I write in the 'server' portion to add one, it just erases what I write
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Edit the apache squirrelmail.conf file and comment out the vhost section that you activted there. then restart apache.
     
  3. sysroot

    sysroot New Member

    Thanks

    Thank you. I did that. seekanet.com still does not resolve when I dig it, and I'm not sure why but I added the DNS Zone in ISPCOnfig3.

    ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> seekanet.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 8360
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

    ;; QUESTION SECTION:
    ;seekanet.com. IN A

    ;; Query time: 4860 msec
    ;; SERVER: 8.8.8.8#53(8.8.8.8)
    ;; WHEN: Wed Aug 28 16:15:37 2013
    ;; MSG SIZE rcvd: 30
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Most likely the zone is incomplete so that named (bind) rejected it. See /var/log/syslog for named errors.
     
  5. sysroot

    sysroot New Member

    tail -f /var/log/syslog Aug 28 23:15:05

    Thank you again till. I don't see anything that references "named" or even "bind" in the log. I do know that I knew it wasnt going to be easy :)

    [email protected]:/etc/apache2/conf.d# tail -f /var/log/syslog
    Aug 28 23:15:05 seekanet pure-ftpd: (?@::1) [INFO] Logout.
    Aug 28 23:15:05 seekanet dovecot: imap-login: Disconnected (disconnected before greeting, waited 0 secs): user=<>, rip=::1, lip=::1, secured, session=<IHjGewjl4wAAAAAAAAAAAAAAAAAAAAAB>
    Aug 28 23:15:05 seekanet dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=::1, lip=::1, secured, session=<XEXHewjlwQAAAAAAAAAAAAAAAAAAAAAB>
    Aug 28 23:15:06 seekanet postfix/smtpd[22644]: warning: database /var/lib/mailman/data/virtual-mailman.db is older than source file /var/lib/mailman/data/virtual-mailman
    Aug 28 23:15:06 seekanet postfix/smtpd[22644]: connect from localhost[::1]
    Aug 28 23:15:06 seekanet postfix/smtpd[22644]: lost connection after CONNECT from localhost[::1]
    Aug 28 23:15:06 seekanet postfix/smtpd[22644]: disconnect from localhost[::1]
    Aug 28 23:16:01 seekanet /USR/SBIN/CRON[22681]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Aug 28 23:17:01 seekanet /USR/SBIN/CRON[22691]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
    Aug 28 23:18:01 seekanet /USR/SBIN/CRON[22701]: (root) CMD (/usr/local/ispconfig/server/server.sh 2>&1 > /dev/null | while read line; do echo `/bin/date` "$line" >> /var/log/ispconfig/cron.log; done)
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Tail -f shows just the last few lines. Use:

    grep named /var/log/syslog

    or

    grep bind /var/log/syslog

    to find the records. Before you do that, modify a record in the dns zone, e.g. set the ttl to a value that is 1 second higher and wait at least one minute, so you can ensure that you get recent bind errors when ispconfig troes to write the zone again.
     
  7. sysroot

    sysroot New Member

    Till

    [email protected]:/etc/postfix# grep bind /var/log/syslog
    [email protected]:/etc/postfix# grep named /var/log/syslog
    [email protected]:/etc/postfix#

    I did however DNS seekanet.com and it does resolve and go to www.seekanet.com now, but thats because I set it under my domain register settings.. so I Went into ISPConfig3 and added the mail and other subdomains. And nothing

    * Dns resolving mail.seekanet.com
    -
    * Dns unable to resolve address mail.seekanet.com
    -
    * Dns resolving ns1.seekanet.com
    -
    * Dns unable to resolve address ns1.seekanet.com
    -
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Mail adn subdomains in the web modz├║le are not related to dns. When you wnat to use your server as dns server, then you have to add a dns zone for it in the dns module.
     
  9. sysroot

    sysroot New Member

    Yes

    Till, I have added a DNS Zone for seekanet.com. I can provide screenshots if you wish. (They are included) :)
     

    Attached Files:

  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The A-Record for ns2 is missing.
     
  11. sysroot

    sysroot New Member

    ARecord

    Thank you. ns2 has been established in the DNS Zone. However, I am pretty sure this isnt' going to resolve the issue. Till :)
     
  12. sysroot

    sysroot New Member

    Till

    Are you still with me Till?

    Its been awhile and the ns1 ns2 and others are not DNSing. seekanet.com resolves only because I pointed the DNS Ip to my server. This is odd.
     

Share This Page