Hell of asp debian apache

Discussion in 'Installation/Configuration' started by ColdDoT, Mar 15, 2006.

  1. ColdDoT

    ColdDoT New Member


    i want to offer my customers asp i know that it can i've you pay chilisoft. but first i will try how much poeple uses asp so i want to set up apache::asp

    i've installed apache::asp but now i must install mod_perl and that i can't get it work i get over and over again compile errors this is what i use

    apache 2.2
    perl 5.8.8
    mod_perl 2.0.2

    this are the compile commands i use

    #perl Makefile.PL MP_APXS=/var/server/webserver/apache/bin/apxs MP_APR_CONFIG=/var/server/webserver/apache/bin/apr-1-config
    (but i get this note)
    Note (probably harmless): No library found for -lperl

    GOOD it says but i get almost only
    /usr/lib/perl/5.8/CORE/proto.h:2010: let op: `warn_unused_result' attribute directive ignored
    and the proto.h:**** is changing all the time

    #make test (there the problem starts i get this)
    /usr/bin/perl -Iblib/arch -Iblib/lib \
    t/TEST -clean
    [warning] setting ulimit to allow core files
    ulimit -c unlimited; /usr/bin/perl /var/server/webserver/mod_perl-2.0.2/t/TEST -clean
    /usr/bin/perl -Iblib/arch -Iblib/lib \
    t/TEST -bugreport -verbose=0
    [warning] setting ulimit to allow core files
    ulimit -c unlimited; /usr/bin/perl /var/server/webserver/mod_perl-2.0.2/t/TEST -bugreport -verbose=0
    [warning] root mode: changing the files ownership to 'nobody' (65534:65534)
    [warning] testing whether 'nobody' is able to -rwx /var/server/webserver/mod_perl-2.0.2/t
    "/usr/bin/perl" -Mlib=/var/server/webserver/mod_perl-2.0.2/Apache-Test/lib -MApache::TestRun -e 'eval { Apache::TestRun::run_root_fs_test(65534, 65534, q[/var/server/webserver/mod_perl-2.0.2/t]) }';

    [warning] result: OK
    [warning] the client side drops 'root' permissions and becomes 'nobody'
    /var/server/webserver/apache/bin/httpd -d /var/server/webserver/mod_perl-2.0.2/t -f /var/server/webserver/mod_perl-2.0.2/t/conf/httpd.conf -D APACHE2 -D PERL_USEITHREADS
    using Apache/2.2.0 (prefork MPM)

    waiting 120 seconds for server to start: .httpd: Syntax error on line 16 of /var/server/webserver/mod_perl-2.0.2/t/conf/httpd.conf: Cannot load /var/server/webserver/mod_perl-2.0.2/src/modules/perl/mod_perl.so into server: /var/server/webserver/mod_perl-2.0.2/src/modules/perl/mod_perl.so: undefined symbol: PL_ppaddr
    [ error]
    server has died with status 255 (t/logs/error_log wasn't created, start the server in the debug mode)
    sh: line 1: 15239 Afgebroken /usr/bin/perl /var/server/webserver/mod_perl-2.0.2/t/TEST -bugreport -verbose=0
    make: *** [run_tests] Fout 143

    greets kevin
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Is there a special reason why you dont use the DEBIAN mod_perl package?
  3. ColdDoT

    ColdDoT New Member

    nvm after i update it all my packages it works all fine now
    Last edited: Mar 15, 2006

Share This Page