Heartbeat / Node problem

Discussion in 'Server Operation' started by mzilla, Apr 15, 2010.

  1. mzilla

    mzilla New Member


    I have read and followed the loadbalancing tutorial at http://www.howtoforge.com/high_availability_loadbalanced_apache_cluster_p3 . When I was setting up my load balanced cluster in my home configuration everything worked just fine. Last week I moved everything to a hosting company and changed some IP's. I changed configuration accordingly but I can't get things to work properly.

    It looks like Heartbeat and ipfail itself are functioning normally. I can access the webserver cluster through the virutal IP and I get responses from different hosts. Everything looks fine. Only problem, the webserver nodes can't reach the internet when lo:0 is up. The ip configuration is like this:

    When I run ifdown lo:0 , I can reach the internet and the internet can reach my server. When I do ifup lo:0 again I can reach the internet for about five more minutes before the server goes away and I can't reach it anymore.

    I have no clue in which direction to look for a solution. Thanks for your help in advance!
  2. mzilla

    mzilla New Member

    To help you better understand the problem, this is the routing table before and after I perform ifup lo:0

  3. mzilla

    mzilla New Member

    The most funny thing of all is that for the first five minutes everything works fine and then suddenly almost all at once the hosts go down. When I look in the log's I can't find anything that could be the cause of it.
  4. mzilla

    mzilla New Member

    Okay, I seem to have solved the problem, at least so I hope. It seems to have to do with the subnetmask of the lo:0 adapter. I had set it to the correct subnetmask for the IP adress of the card. This is not correct, the subnetmask of lo:0 should always be . I am not yet 100% sure this solved it but it looks good!

Share This Page