Having trouble login/finding Zenoss

Discussion in 'Server Operation' started by badgerbox76, Dec 9, 2006.

  1. badgerbox76

    badgerbox76 Member

    Here is what i have done

    I used ispconfig to create a mysql database for Zenoss. I then used that database for the install. Every thing seemed fine at the end of the install i a believe all the parts where install properly. I have check the database and it has tables. I am not sure where the php files for Zenoss have gone. I type in http://192.168.0.105:8080/zport/dmd and get nothing. So what should i do?
     
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    I dont know zenoss.
    But just try to locate the php file on the harddist with
    find / -name FILENAME
    or
    locate FILENAME

    with locate you should maybe run updatedb first.

    In case of you expect any daemon running on prot 8080, chjeck netstat -tap to see if there is a process running on that port.
     
  3. badgerbox76

    badgerbox76 Member

    Here is where the files are

    adm[email protected]:/usr/local/zenoss$ sudo find / -name zenoss
    /etc/init.d/zenoss
    /home/zenoss
    /usr/local/zenoss
    /usr/local/zenoss/bin/zenoss
    /usr/local/zenoss/Products/DataCollector/plugins/zenoss
    [email protected]:/usr/local/zenoss$

    I have looked through all the directory's and i could not find any php files but even if i did i would need to move them to /var/www so that i apache/ispconfig could host them, right? What should i do now? I still don't know how or where to log into zenoss. Please help me out. Thanks
     
  4. falko

    falko Super Moderator ISPConfig Developer

    I don't know Zenoss either, but it seems as if it comes with its own web server (on port 8080 - or is your main Apache running on that port?), so you don't need to move PHP files to /var/www.
     
  5. badgerbox76

    badgerbox76 Member

    Well apache was not setup to run on port 8080 so i added the port to the ports.conf file but i still am unable to get anything at http://192.168.0.105:8080/ What should i try next?
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. badgerbox76

    badgerbox76 Member

    If you look in my previous massage you will see that port 8080 was not in my ports.conf file so i added the port but it did not change anything. Also i was looking over the howto again and i has you install php and apache so i don't think it runs off it's own server. What should i try now? Also thanks for all your great support and understanding. I am still working on game server howto and should be done this week or next.
     
  8. falko

    falko Super Moderator ISPConfig Developer

    Did you see any errors during Zenoss installation? Do you see Zenoss in the output of
    Code:
    ps aux
    ? Is there a Zenoss init script in /etc/init.d?
     
  9. badgerbox76

    badgerbox76 Member

    No i did not see any errors during the installation.

    I could not find Zenoss in the log

    Yes is did find zenoss in the /etc/init.d dircotry
    Code:
    [email protected]:/etc/init.d$ ls
    acpid                                          mountvirtfs
    acpi-support                                   mtab
    alsa-utils                                     mysql
    anacron                                        mysql-ndb
    apache2                                        mysql-ndb-mgm
    apmd                                           networking
    atd                                            nvidia-kernel
    bastille-firewall                              pcmciautils
    bastille-firewall.backup_12_07_2006__20_04_11  postfix
    bind9                                          powernowd
    bootclean.sh                                   powernowd.early
    bootlogd                                       ppp
    bootmisc.sh                                    pppd-dns
    checkfs.sh                                     procps.sh
    checkroot.sh                                   proftpd
    console-screen.sh                              quota
    courier-authdaemon                             quotarpc
    courier-imap                                   rc
    courier-imap-ssl                               rc.local
    courier-pop                                    rcS
    courier-pop-ssl                                readahead
    cron                                           readahead-desktop
    cupsys                                         README
    dbus                                           reboot
    dns-clean                                      rmnologin
    evms                                           rsync
    fetchmail                                      saslauthd
    gdm                                            screen
    glibc.sh                                       sendsigs
    halt                                           single
    hdparm                                         skeleton
    hostname.sh                                    snmpd
    hotkey-setup                                   ssh
    hplip                                          stop-bootlogd
    hwclock.sh                                     stop-readahead
    ispconfig_server                               sysklogd
    keymap.sh                                      udev
    klogd                                          umountfs
    laptop-mode                                    umountnfs.sh
    linux-restricted-modules-common                umountroot
    loopback                                       urandom
    lvm                                            usplash
    makedev                                        vbesave
    mdadm                                          waitnfs.sh
    mdadm-raid                                     x11-common
    module-init-tools                              zenoss
    mountall.sh                                    zenoss.save
    mountdevsubfs
    [email protected]:/etc/init.d$
    

    I can't tell if it started. Also i did not even know i needed a password to start it. Can i set ispconfig to start with out a password and Zenoss to do the same?
    Code:
    [email protected]:/etc/init.d$ sudo zenoss start
    Password:
    sudo: zenoss: command not found
    [email protected]:/etc/init.d$ sudo ./zenoss start
     Adding system startup for /etc/init.d/zenoss ...
       /etc/rc0.d/K95zenoss -> ../init.d/zenoss
       /etc/rc1.d/K95zenoss -> ../init.d/zenoss
       /etc/rc6.d/K95zenoss -> ../init.d/zenoss
       /etc/rc2.d/S95zenoss -> ../init.d/zenoss
       /etc/rc3.d/S95zenoss -> ../init.d/zenoss
       /etc/rc4.d/S95zenoss -> ../init.d/zenoss
       /etc/rc5.d/S95zenoss -> ../init.d/zenoss
     System startup links for /etc/init.d/zenoss already exist.
    Daemon: zeoctl . . daemon process started, pid=25197
    Daemon: zopectl . daemon process started, pid=25201
    Daemon: zenxevent starting...
    Daemon: zenmodeler starting...
    Daemon: zenperfsnmp starting...
    Daemon: zenperfxmlrpc starting...
    Daemon: zenprocess starting...
    Daemon: zenping starting...
    Password:
    Sorry, try again.
    Password:
    Sorry, try again.
    Password:
    Sorry, try again.
    sudo: 3 incorrect password attempts
    Daemon: zensyslog starting...
    Password:
    Sorry, try again.
    Password:
    Sorry, try again.
    Password:
    Sorry, try again.
    sudo: 3 incorrect password attempts
    Daemon: zenstatus starting...
    Daemon: zenactions starting...
    Daemon: zentrap starting...
    Password:
    Daemon: zencommand starting...
    
     
  10. falko

    falko Super Moderator ISPConfig Developer

    If you need a password to start ISPConfig, you did something wrong during installation. Have a look here: http://www.ispconfig.org/manual_installation.htm

    I really don't know. :(
     
  11. Ben

    Ben ISPConfig Developer ISPConfig Developer

    But then there should either be any error output whe starting zenoss via initscript, it should appear in netstat -tap or at least in ps -aux if zenoss is running.

    Can you upload (no copy + paste) the initscript for zenoss here?
     

Share This Page