Having lots of problems with Postfix not delivering message

Discussion in 'Installation/Configuration' started by maxeaves, Feb 28, 2011.

  1. maxeaves

    maxeaves New Member

    Dear All,

    I've just come off an old Plesk server, and have talking the drop in building my own webserver and mailserver using ISPConfig. I followed the instructions on the main site for building the perfect Centos box...even paid for the manual....but still I am well and truly stumped at the moment.

    Synopsis: The mail server is receiving mail, but it will not deliver the mail to my inbox....at all!

    so - this box has two domains - neither domain is able to deliver mail locally.

    Typically - junk mail - seems to be correctly banned:

    Feb 28 19:36:45 1400gtr postfix/smtpd[3969]: NOQUEUE: reject: RCPT from unknown[212.31.107.182]: 554 5.7.1 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<static-nbl2-182.cytanet.com.cy>
    Feb 28 19:36:45 1400gtr postfix/smtpd[3969]: lost connection after RCPT from unknown[212.31.107.182]
    Feb 28 19:36:45 1400gtr postfix/smtpd[3969]: disconnect from unknown[212.31.107.182]

    However, even for legitimate email, I am still getting bounced back messages - Relay access denied.

    What log files can I sent to you, so you can give me some pointers?

    Checks I have made:
    1) Postfix is definately an MySQL roled version
    2) amavisd is definately running

    I am keen to learn, but feeling frustrated....

    Thanks


    Max
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please login to a mailbox of that domain by webmail and send a message to the same mailbox email address that you used to login and post all messages that get added to the mail.log.
     
  3. maxeaves

    maxeaves New Member

    Hi there,

    Yep - That failed....

    Sanitised log output:

    Feb 28 20:06:18 1400gtr postfix/smtp[5557]: 770913330120: to=<[email protected]>, relay=none, delay=0.01, delays=0/0/0/0, dsn=5.4.6, status=bounced (mail for domain.co.uk loops back to myself)
    Feb 28 20:06:18 1400gtr postfix/qmgr[4863]: 770913330120: removed
    Feb 28 20:06:20 1400gtr dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
    Feb 28 20:06:20 1400gtr dovecot: IMAP([email protected]): Disconnected: Logged out bytes=640/459
    Feb 28 20:06:22 1400gtr dovecot: IMAP([email protected]): Disconnected: Logged out bytes=117/1401
    Feb 28 20:06:22 1400gtr dovecot: imap-login: Login: user=<[email protected]>, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, secured
     
  4. maxeaves

    maxeaves New Member

    It is as though for some reason....this domain of mine - is not actually in the list of approved final destinations, although all the DNS correctly point to this IP address. I've tried removing the domain and re-adding it back into ISPConfig, but still no joy....
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks like there is a problem in your postfix base setup. In postfix, you can not use a domain as virtual domain for email addresses that is used as server hostname. Thats why the perfect setup guides instruct you to use a server hostname like server1.example.com and not example.com.

    According to the log, you used domain.co.uk as server hostname or mydomain setting in postfix, which causes postfix to fail now.

    Please open the postfix main.cf file and the /etc/mailname file (if exists) and replace all occurrences of mydomain with a subdomain like server1.domain.co.uk or mail.domain.co.uk. Then restart postfix and create a dns A-Record in the dns zone of the domain domain.co.uk for the subdomain that you used in the postfix configuration that points to the ip address of the server.
     
  6. maxeaves

    maxeaves New Member

    oh god - the penny now drops -

    Sorry, this is my first time in setting up my own server for use with mail and my first time using postfix; I will give that a go and get back to you with my results.

    Thanks


    Max
     

Share This Page