Having login issues with ISPconfig3 after several months of use.

Discussion in 'General' started by merovinq, Jul 27, 2011.

  1. merovinq

    merovinq New Member

    I use ispconfig 3 on several servers for years and really love it. It gets better with every release.

    I am having this issue on 1 server, not sure when it started, but I am no longer able to login.

    It does not do the normal:
    Error
    Username or Password wrong.

    as it does on my other servers when typing the wrong password.

    I've upgraded it to the newest release using the upgrade script, but have the same results.

    You can view the problem here: http://208.64.37.102:8080

    Anyone know what I can do to fix this?
     
    Last edited: Jul 27, 2011
  2. till

    till Super Moderator

    Looks like a problem with the mysql database, e.g. a crashed database table. Please login to phpmyadmin and check all tables of the ispconfig database with the mysql check and repair functions.
     
  3. merovinq

    merovinq New Member

    It seems that I am also having issues logging into phpmyadmin as well... I don't use it much as I usually use Navicat Mysql to manage my databases.

    phpMyAdmin is doing the exact same thing as ispconfig3. Does not login and no error message.

    I repaired the dbispconfig table in Navicat Mysql as well as the mysql table, but am still having the same issue. very strange, going to lookup this problem for phpMyAdmin and see if that can help me solve both problems.
     
  4. falko

    falko Super Moderator

    Is this a virtual machine or a physical server?

    Maybe PHP needs more RAM than is available?
     
  5. merovinq

    merovinq New Member

    That is not it, the server is a physical box I built and colocated with many websites on it with a 6 core AMD phenom II with 8GB of ram.

    I did not get much time to look into it yesterday except I saw that other have reported this problem with phpMyAdmin... I hope to have time this afternoon to look into it more.
     
  6. falko

    falko Super Moderator

    Please let us know if you find out more. Did you check your logs?
     
  7. merovinq

    merovinq New Member

    here are the apache logs from an attempted login...

    xxx - - [02/Aug/2011:09:23:55 -0500] "POST /content.php HTTP/1.1" 200 446 "http://208.64.37.102:8080/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0"
    xxx - - [02/Aug/2011:09:23:55 -0500] "GET /nav.php?nav=side HTTP/1.1" 200 51 "http://208.64.37.102:8080/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0"
    xxx - - [02/Aug/2011:09:23:55 -0500] "GET /nav.php?nav=top HTTP/1.1" 200 113 "http://208.64.37.102:8080/" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0"

    (Firebug also shows 200 replies.)


    Here are the mysql queries that are performed...

    110802 9:36:16 1248 Connect ispconfig@localhost on
    1248 Query SET NAMES utf8
    1248 Query SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
    1248 Init DB dbispconfig
    1248 Query SELECT * FROM sys_session WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
    1248 Init DB dbispconfig
    1248 Query UPDATE sys_session SET last_updated = '2011-08-02 09:36:16' WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
    1248 Init DB dbispconfig
    1248 Query DELETE FROM sys_session WHERE last_updated < '2011-08-02 09:12:16'
    1248 Quit
    1249 Connect ispconfig@localhost on
    1249 Query SET NAMES utf8
    1249 Query SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
    1249 Init DB dbispconfig
    1249 Query SELECT * FROM sys_session WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
    1249 Init DB dbispconfig
    1249 Query UPDATE sys_session SET last_updated = '2011-08-02 09:36:16' WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
    1249 Init DB dbispconfig
    1249 Query DELETE FROM sys_session WHERE last_updated < '2011-08-02 09:12:16'
    1249 Quit
    1250 Connect ispconfig@localhost on
    1250 Query SET NAMES utf8
    1250 Query SET character_set_results = 'utf8', character_set_client = 'utf8', character_set_connection = 'utf8', character_set_database = 'utf8', character_set_server = 'utf8'
    1250 Init DB dbispconfig
    1250 Query SELECT * FROM sys_session WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
    1250 Init DB dbispconfig
    1250 Query UPDATE sys_session SET last_updated = '2011-08-02 09:36:16' WHERE session_id = '6226d4d569dc0cd54b691b67b565906d'
    1250 Init DB dbispconfig
    1250 Query DELETE FROM sys_session WHERE last_updated < '2011-08-02 09:12:16'
    1250 Quit

    I'm still stuck as to what is causing this...
     
  8. till

    till Super Moderator

    Have you been able to fix the issue with phpmyadmin? Have you tried a different browser? It might be that the login fails when the browser ahs some ad or scriptblock extensions installed or it does not accept the session cookies from phpmyadmin and ispconfig.
     
  9. merovinq

    merovinq New Member

    No it seems like the same issue with both ispconfig and phpmyadmin though...

    Switching browsers does not fix the issue and logging onto an ispconfig installation on a different server works fine.
     
  10. merovinq

    merovinq New Member

    I've been so busy starting another business, I have not had time to mess with this cause every is configured how I need at the moment. However I need to get on ispconfig and change FTP settings in the next 24-48 hours and I don't even know where to start on fixing this problem.

    If anyone has any suggestions I have not tried yet, it would be much appreciated.
     
  11. till

    till Super Moderator

    Which Linux distribution do you use?
     
  12. merovinq

    merovinq New Member

    debian lenny
     
  13. till

    till Super Moderator

    Please try to change the field length of the field session_id in the sys_session table to varchar 64 with phpmyadmin. And are there any error in the apache error.log, especially related to vlogger?
     
  14. merovinq

    merovinq New Member

    I changed the length of the session_id field from 32 to 64 in the sys_session table of the dbispconfig database... does the same thing.

    Also there is no errors in the /var/log/apache2/error.log when trying to post the login information
     
  15. merovinq

    merovinq New Member

    I do remember at one point several months ago I was using sshfs from a laptop to connect to the server's file system.... and it somehow messed up the permissions of my / directory (i think).

    When this happened all of my websites went offline and I spend around an hour to figure out the problem. fixed the permission problem. and my websites were working again... I think this might have something to do with my problem now that I think back.

    However I've given the phpmyadmin/ispconfig web application temporary 777 permissions and seems to be the same...
     

Share This Page