Having issues with server. Can't receive e-mail

Discussion in 'Installation/Configuration' started by bigmatlem, Dec 4, 2016.

  1. bigmatlem

    bigmatlem New Member

    Here is the log:
    [email protected]:/var/log# Dec 3 19:13:42 host2600 postfix/smtpd[20198]: warning: mysql:/etc/postfix/mysql-virtual_client.cf: table lookup problem
    No command 'Dec' found, did you mean:
    Command 'zec' from package 'zec' (universe)
    Command 'sec' from package 'sec' (universe)
    Command 'rec' from package 'sox' (universe)
    Dec: command not found
    [email protected]:/var/log# Dec 3 19:13:42 host2600 postfix/smtpd[20198]: NOQUEUE: reject: RCPT from mail-pg0-f48.google.com[74.125.83.48]: 451 4.3.5 <mail-pg0-f48.google.com[74.125.83.48]>: Client host rejected: Server configuration error; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<mail-pg0-f48.google.com>
    bash: syntax error near unexpected token `newline'
    [email protected]:/var/log# Dec 3 19:13:42 host2600 postfix/smtpd[20198]: disconnect from mail-pg0-f48.google.com[74.125.83.48]
    No command 'Dec' found, did you mean:
    Command 'zec' from package 'zec' (universe)
    Command 'sec' from package 'sec' (universe)
    Command 'rec' from package 'sox' (universe)
    Dec: command not found
    [email protected]:/var/log#

    What is going on with this thing? Installing ISPCONFIG was never such a challenge before 3.1.1 appeared. It is running 12.04.5 Ubuntu i386
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The installation has not been changed, it's still the same procedure.

    Ubuntu 12.04 is really old, it might be that some of it's software versions are too old. There must be other errors in the mail.log e.g. when you restart postfix, the errors that you posted above are caused by pasting lines from the mail log to the shell.
     
  3. bigmatlem

    bigmatlem New Member

    Found the problem. It's in the setup procedure for 16.04. If you comment out this line mail works perfectly:
    -o smtpd_client_restrictions=permit_sasl_authenticated,reject If it's in forget it. I'll look into it later. It is weird because it works fine with the CentOS7 installation but in Ubuntu it freaks out.
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The line is correct and should be in the ubuntu file as well. You might have missed to remove the # in front of the submission or smtps line.
     
  5. bigmatlem

    bigmatlem New Member

    Nope. Both enabled. I'll spin up a VM on virtualbox and tinker with it outside of a production unit.
     

Share This Page